Skip to content
Snippets Groups Projects
Commit 7af52bd5 authored by Sree Harsha Totakura's avatar Sree Harsha Totakura Committed by Ludovic Courtès
Browse files

gnu: gnunet: Fix failing testcases.


* gnu/packages/gnunet.scm (gnurl): Add pkg-config.
* gnu/packages/patches/gnunet-fix-tests.patch: Append fix for integration testcases.

Signed-off-by: default avatarLudovic Courtès <ludo@gnu.org>
parent bdff90a1
No related branches found
No related tags found
No related merge requests found
...@@ -153,8 +153,9 @@ (define-public gnurl ...@@ -153,8 +153,9 @@ (define-public gnurl
("libidn" ,libidn) ("libidn" ,libidn)
("zlib" ,zlib))) ("zlib" ,zlib)))
(native-inputs (native-inputs
`(("perl" ,perl) `(("groff" ,groff)
("groff" ,groff) ("perl" ,perl)
("pkg-config" ,pkg-config)
("python" ,python-2))) ("python" ,python-2)))
(arguments (arguments
`(#:configure-flags '("--enable-ipv6" "--with-gnutls" "--without-libssh2" `(#:configure-flags '("--enable-ipv6" "--with-gnutls" "--without-libssh2"
...@@ -211,7 +212,8 @@ (define-public gnunet ...@@ -211,7 +212,8 @@ (define-public gnunet
(search-patch "gnunet-fix-scheduler.patch") (search-patch "gnunet-fix-scheduler.patch")
;; Patch to fix bugs in testcases: ;; Patch to fix bugs in testcases:
;; * Disable peerinfo-tool tests as they depend on reverse DNS lookups ;; * Disable peerinfo-tool tests as they depend on reverse DNS lookups
;; * Allow revocation testcase to run on loopback; upstream: #32130 ;; * Allow revocation and integration-tests testcases to run on
;; loopback; upstream: #32130, #32326
;; * Skip GNS testcases requiring DNS lookups; upstream: #32118 ;; * Skip GNS testcases requiring DNS lookups; upstream: #32118
(search-patch "gnunet-fix-tests.patch"))) (search-patch "gnunet-fix-tests.patch")))
(patch-flags '("-p0")))) (patch-flags '("-p0"))))
......
...@@ -44,3 +44,15 @@ Index: src/gns/test_gns_cname_lookup.sh ...@@ -44,3 +44,15 @@ Index: src/gns/test_gns_cname_lookup.sh
rm -rf /tmp/test-gnunet-gns-peer-1/ rm -rf /tmp/test-gnunet-gns-peer-1/
TEST_DOMAIN_PLUS="www.gnu" TEST_DOMAIN_PLUS="www.gnu"
Index: src/integration-tests/confs/test_defaults.conf
===================================================================
--- src/integration-tests/confs/test_defaults.conf (revision 32320)
+++ src/integration-tests/confs/test_defaults.conf (working copy)
@@ -17,6 +17,7 @@
EXTERNAL_ADDRESS = 127.0.0.1
INTERNAL_ADDRESS = 127.0.0.1
BINDTO = 127.0.0.1
+RETURN_LOCAL_ADDRESSES = YES
[hostlist]
SERVERS =
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment