Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
7c88b6bd
Commit
7c88b6bd
authored
9 years ago
by
Andy Wingo
Committed by
Mark H Weaver
9 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add gusb.
* gnu/packages/gnome.scm (gusb): New variable.
parent
3bc45449
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/gnome.scm
+45
-0
45 additions, 0 deletions
gnu/packages/gnome.scm
with
45 additions
and
0 deletions
gnu/packages/gnome.scm
+
45
−
0
View file @
7c88b6bd
...
@@ -3162,3 +3162,48 @@ (define-public gvfs
...
@@ -3162,3 +3162,48 @@ (define-public gvfs
GVFS comes with a set of backends, including trash support, SFTP, SMB, HTTP,
GVFS comes with a set of backends, including trash support, SFTP, SMB, HTTP,
DAV, and others."
)
DAV, and others."
)
(
license
license:lgpl2
.
0
+
)))
(
license
license:lgpl2
.
0
+
)))
(
define-public
gusb
(
package
(
name
"gusb"
)
(
version
"0.2.6"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/hughsie/libgusb/archive/"
"gusb_"
(
string-join
(
string-split
version
#\.
)
"_"
)
".tar.gz"
))
(
sha256
(
base32
"0h9dzaza81b0mx5jfh5cnc31xdynl0jsxgwvl6vqyhy8mnwfi5nr"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"glib:bin"
,
glib
"bin"
)
; for glib-genmarshal, etc.
(
"gobject-introspection"
,
gobject-introspection
)
(
"pkg-config"
,
pkg-config
)
(
"vala"
,
vala
)
(
"autoconf"
,
autoconf
)
(
"automake"
,
automake
)
(
"libtool"
,
libtool
)
(
"gtk-doc"
,
gtk-doc
)))
(
propagated-inputs
;; Both of these are required by gusb.pc.
`
((
"glib"
,
glib
)
(
"libusb"
,
libusb
)))
(
arguments
`
(
#
:tests?
#f
; libusb fails to initialize. Wonder what that is.
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'autogen
(
lambda
_
(
and
(
zero?
(
system*
"gtkdocize"
))
(
zero?
(
system*
"autoreconf"
"-vif"
))))))))
(
home-page
"https://github/hughsie/libgusb"
)
(
synopsis
"A GLib binding for libusb1"
)
(
description
"GUsb is a GObject wrapper for libusb1 that makes it easy to do
asynchronous control, bulk and interrupt transfers with proper cancellation
and integration into a mainloop. This makes it easy to integrate low level
USB transfers with your high-level application or system daemon."
)
(
license
license:lgpl2
.
1
+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment