Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
7d3a1a2d
Commit
7d3a1a2d
authored
9 years ago
by
Ben Woodcroft
Committed by
Ricardo Wurmus
9 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add ruby-ansi.
* gnu/packages/ruby.scm (ruby-ansi): New variable.
parent
5dfd2766
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ruby.scm
+36
-0
36 additions, 0 deletions
gnu/packages/ruby.scm
with
36 additions
and
0 deletions
gnu/packages/ruby.scm
+
36
−
0
View file @
7d3a1a2d
...
...
@@ -2894,3 +2894,39 @@ (define-public ruby-eventmachine
used to create both network servers and clients."
)
(
home-page
"http://rubyeventmachine.com"
)
(
license
(
list
license:ruby
license:gpl3
))))
; GPLv3 only AFAICT
(
define-public
ruby-ansi
(
package
(
name
"ruby-ansi"
)
(
version
"1.5.0"
)
(
source
(
origin
(
method
url-fetch
)
;; Fetch from GitHub as the gem does not contain testing code.
(
uri
(
string-append
"https://github.com/rubyworks/ansi/archive/"
version
".tar.gz"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"1zdip30hivyipi8hndhb457bhiz033awd00bgrsk5axjrwp6zhly"
))))
(
build-system
ruby-build-system
)
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
;; Disable testing to break the cycle ansi, ae, ansi, as well as the
;; cycle ansi, qed, ansi. Instead simply test that the library can
;; be require'd.
(
replace
'check
(
lambda
_
(
zero?
(
system*
"ruby"
"-Ilib"
"-r"
"ansi"
)))))))
(
synopsis
"ANSI escape code related libraries"
)
(
description
"This package is a collection of ANSI escape code related libraries
enabling ANSI colorization and stylization of console output. Included in the
library are the @code{Code} module, which defines ANSI codes as constants and
methods, a @code{Mixin} module for including color methods, a @code{Logger}, a
@code{ProgressBar}, and a @code{String} subclass. The library also includes a
@code{Terminal} module which provides information about the current output
device."
)
(
home-page
"http://rubyworks.github.io/ansi"
)
(
license
license:bsd-2
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment