Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
83a2e492
Commit
83a2e492
authored
9 years ago
by
Sou Bunnbu (宋文武)
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add accountsservice.
* gnu/packages/freedesktop.scm (accountsservice): New variable.
parent
86aff791
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/freedesktop.scm
+39
-0
39 additions, 0 deletions
gnu/packages/freedesktop.scm
with
39 additions
and
0 deletions
gnu/packages/freedesktop.scm
+
39
−
0
View file @
83a2e492
...
@@ -372,3 +372,42 @@ (define-public udisks
...
@@ -372,3 +372,42 @@ (define-public udisks
message bus."
)
message bus."
)
;; The dynamic library are under LGPLv2+, others are GPLv2+.
;; The dynamic library are under LGPLv2+, others are GPLv2+.
(
license
(
list
license:gpl2+
license:lgpl2
.
0
+
))))
(
license
(
list
license:gpl2+
license:lgpl2
.
0
+
))))
(
define-public
accountsservice
(
package
(
name
"accountsservice"
)
(
version
"0.6.40"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://www.freedesktop.org/software/"
name
"/"
name
"-"
version
".tar.xz"
))
(
sha256
(
base32
"0ayb3y3l25dmwxlh9g071h02mphjfbkvi2k5f635bayb01k7akzh"
))))
(
build-system
gnu-build-system
)
(
arguments
'
(
#
:tests?
#f
; XXX: tests require DocBook 4.1.2
#
:configure-flags
'
(
"--localstatedir=/var"
)
#
:phases
(
modify-phases
%standard-phases
(
add-before
'configure
'pre-configure
(
lambda
_
;; Don't try to create /var/lib/AccoutsService.
(
substitute*
"src/Makefile.in"
((
"\\$\\(MKDIR_P\\).*/lib/AccountsService.*"
)
"true"
)))))))
(
native-inputs
`
((
"glib:bin"
,
glib
"bin"
)
; for gdbus-codegen, etc.
(
"gobject-introspection"
,
gobject-introspection
)
(
"intltool"
,
intltool
)
(
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"polkit"
,
polkit
)))
(
home-page
"http://www.freedesktop.org/wiki/Software/AccountsService/"
)
(
synopsis
"D-Bus interface for user account query and manipulation"
)
(
description
"The AccountService project provides a set of D-Bus interfaces for querying
and manipulating user account information and an implementation of these
interfaces, based on the useradd, usermod and userdel commands."
)
(
license
license:gpl3+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment