Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
8731e527
Commit
8731e527
authored
10 years ago
by
John Darrington
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add maxima.
* gnu/packages/maths.scm (maxima): New variable.
parent
f842bbed
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/maths.scm
+39
-0
39 additions, 0 deletions
gnu/packages/maths.scm
with
39 additions
and
0 deletions
gnu/packages/maths.scm
+
39
−
0
View file @
8731e527
...
...
@@ -43,9 +43,11 @@ (define-module (gnu packages maths)
#
:use-module
(
gnu
packages
ghostscript
)
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
less
)
#
:use-module
(
gnu
packages
lisp
)
#
:use-module
(
gnu
packages
gnome
)
#
:use-module
(
gnu
packages
xorg
)
#
:use-module
(
gnu
packages
gl
)
#
:use-module
(
gnu
packages
m4
)
#
:use-module
(
gnu
packages
mpi
)
#
:use-module
(
gnu
packages
multiprecision
)
#
:use-module
(
gnu
packages
pcre
)
...
...
@@ -827,3 +829,40 @@ (define-public gsegrafix
polar-axis plots and three-dimensional plots. Plots can be printed or saved
to BMP, JPEG or PNG image formats."
)
(
license
license:gpl3+
)))
(
define-public
maxima
(
package
(
name
"maxima"
)
(
version
"5.33.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/maxima/Maxima-source/"
version
"-source/"
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"13axm11xw0f3frx5b0qdidi7igkn1524fzz77s9rbpl2yy2nrbz2"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:phases
(
alist-cons-before
'check
'pre-check
(
lambda
_
(
chmod
"src/maxima"
#o555
))
%standard-phases
)))
(
inputs
`
((
"gcl"
,
gcl
)))
(
native-inputs
`
((
"texinfo"
,
texinfo
)
(
"perl"
,
perl
)))
(
home-page
"http://maxima.sourceforge.net"
)
(
synopsis
"Numeric and symbolic expression manipulation"
)
(
description
"Maxima is a system for the manipulation of symbolic and
numerical expressions. It yields high precision numeric results by using
exact fractions, arbitrary precision integers, and variable precision floating
point numbers"
)
;; Some files are lgpl2.1+. Some are gpl2+. Some explicitly state gpl1+.
;; Others simply say "GNU General Public License" without stating a
;; version (which implicitly means gpl1+).
;; At least one file (src/maxima.asd) says "version 2."
;; GPLv2 only is therefore the smallest subset.
(
license
license:gpl2
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment