Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
88f70665
Commit
88f70665
authored
9 years ago
by
Andy Wingo
Committed by
Mark H Weaver
9 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add gnome-terminal.
* gnu/packages/gnome.scm (gnome-terminal): New variable.
parent
43754738
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/gnome.scm
+50
-0
50 additions, 0 deletions
gnu/packages/gnome.scm
with
50 additions
and
0 deletions
gnu/packages/gnome.scm
+
50
−
0
View file @
88f70665
...
...
@@ -5,6 +5,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -42,6 +43,7 @@ (define-module (gnu packages gnome)
#
:use-module
(
gnu
packages
gnutls
)
#
:use-module
(
gnu
packages
iso-codes
)
#
:use-module
(
gnu
packages
libcanberra
)
#
:use-module
(
gnu
packages
linux
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
pkg-config
)
...
...
@@ -1668,3 +1670,51 @@ (define-public gnome-mines
"Mines (previously gnomine) is a puzzle game where you locate mines
floating in an ocean using only your brain and a little bit of luck."
)
(
license
license:gpl2+
)))
(
define-public
gnome-terminal
(
package
(
name
"gnome-terminal"
)
(
version
"3.16.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://gnome/sources/"
name
"/"
(
version-major+minor
version
)
"/"
name
"-"
version
".tar.xz"
))
(
sha256
(
base32
"1s3zwqxs4crlqmh6l7s7n87pbmh2nnjdvhxlkalh58pbl0bk0qrd"
))))
(
build-system
glib-or-gtk-build-system
)
(
arguments
'
(
#
:configure-flags
(
list
"--disable-migration"
"--disable-search-provider"
"--without-nautilus-extension"
)
#
:phases
(
modify-phases
%standard-phases
(
add-before
configure
patch-/bin/true
(
lambda
_
(
substitute*
"configure"
((
"/bin/true"
)
(
which
"true"
))))))))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"desktop-file-utils"
,
desktop-file-utils
)
(
"intltool"
,
intltool
)
(
"itstool"
,
itstool
)))
(
inputs
`
((
"gtk+"
,
gtk+
)
(
"vte"
,
vte
)
(
"gnutls"
,
gnutls
)
(
"dconf"
,
dconf
)
(
"gsettings-desktop-schemas"
,
gsettings-desktop-schemas
)
(
"util-linux"
,
util-linux
)
(
"vala"
,
vala
)))
(
home-page
"https://wiki.gnome.org/Apps/Terminal"
)
(
synopsis
"Terminal emulator"
)
(
description
"GNOME Terminal is a terminal emulator application for accessing a
UNIX shell environment which can be used to run programs available on
your system.
It supports several profiles, multiple tabs and implements several
keyboard shortcuts."
)
(
license
license:gpl3+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment