Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
8957241d
Commit
8957241d
authored
9 years ago
by
Andreas Enge
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add enblend-enfuse.
* gnu/packages/photo.scm (enblend-enfuse): New variable.
parent
f03c0e01
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/photo.scm
+55
-1
55 additions, 1 deletion
gnu/packages/photo.scm
with
55 additions
and
1 deletion
gnu/packages/photo.scm
+
55
−
1
View file @
8957241d
...
...
@@ -25,15 +25,25 @@ (define-module (gnu packages photo)
#
:use-module
(
guix
download
)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
utils
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
boost
)
#
:use-module
(
gnu
packages
compression
)
#
:use-module
(
gnu
packages
ghostscript
)
#
:use-module
(
gnu
packages
gl
)
#
:use-module
(
gnu
packages
graphics
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
imagemagick
)
#
:use-module
(
gnu
packages
libusb
)
#
:use-module
(
gnu
packages
maths
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
popt
)
#
:use-module
(
gnu
packages
readline
))
#
:use-module
(
gnu
packages
readline
)
#
:use-module
(
gnu
packages
web
)
#
:use-module
(
gnu
packages
xfig
)
#
:use-module
(
gnu
packages
xml
))
(
define-public
libraw
(
package
...
...
@@ -204,3 +214,47 @@ (define-public libpano13
Panorama Tools project for building panoramic images from a set of
overlapping images, as well as some command line tools."
)
(
license
license:gpl2+
)))
(
define-public
enblend-enfuse
(
package
(
name
"enblend-enfuse"
)
(
version
"4.1.3"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/enblend/"
name
"/"
name
"-"
(
version-major+minor
version
)
"/"
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"1b7r1nnwaind0344ckwggy0ghl0ipbk9jzylsxcjfl05rnasw00w"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"perl"
,
perl
)
(
"perl-timedate"
,
perl-timedate
)
;; for building the documentation
(
"gnuplot"
,
gnuplot
)
(
"imagemagick"
,
imagemagick
)
(
"libxml2"
,
libxml2
)
(
"tidy"
,
tidy
)
(
"transfig"
,
transfig
)))
(
inputs
`
((
"boost"
,
boost
)
(
"gsl"
,
gsl
)
(
"lcms"
,
lcms
)
(
"libjpeg"
,
libjpeg
)
(
"libpng"
,
libpng
)
(
"libtiff"
,
libtiff
)
(
"openexr"
,
openexr
)
(
"vigra"
,
vigra
)
(
"zlib"
,
zlib
)))
(
arguments
`
(
#
:configure-flags
`
(
"--enable-openmp"
)))
(
home-page
"http://enblend.sourceforge.net/"
)
(
synopsis
"Tools for combining and blending images"
)
(
description
"Enblend blends away the seams in a panoramic image mosaic using a
multi-resolution spline. Enfuse merges different exposures of the same
scene to produce an image that looks much like a tone-mapped image."
)
(
license
license:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment