Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
8bc9515d
Commit
8bc9515d
authored
10 years ago
by
Eric Bavier
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add Eval-Closure.
* gnu/packages/perl.scm (perl-eval-closure): New variable.
parent
4400eb95
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/perl.scm
+32
-0
32 additions, 0 deletions
gnu/packages/perl.scm
with
32 additions
and
0 deletions
gnu/packages/perl.scm
+
32
−
0
View file @
8bc9515d
...
@@ -485,6 +485,38 @@ (define-public perl-dist-checkconflicts
...
@@ -485,6 +485,38 @@ (define-public perl-dist-checkconflicts
modules separately and deal with them after the module is done installing."
)
modules separately and deal with them after the module is done installing."
)
(
license
(
package-license
perl
))))
(
license
(
package-license
perl
))))
(
define-public
perl-eval-closure
(
package
(
name
"perl-eval-closure"
)
(
version
"0.12"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://cpan/authors/id/D/DO/DOY/"
"Eval-Closure-"
version
".tar.gz"
))
(
sha256
(
base32
"0ssvlgx3y1y28wrrp0lmmffzqxfrwb2lb3p60b8cjvxsf1c3jbfv"
))))
(
build-system
perl-build-system
)
(
native-inputs
`
((
"perl-test-fatal"
,
perl-test-fatal
)
(
"perl-test-requires"
,
perl-test-requires
)))
(
propagated-inputs
`
((
"perl-devel-lexalias"
,
perl-devel-lexalias
)))
(
home-page
"http://search.cpan.org/dist/Eval-Closure"
)
(
synopsis
"Safely and cleanly create closures via string eval"
)
(
description
"String eval is often used for dynamic code generation. For
instance, Moose uses it heavily, to generate inlined versions of accessors and
constructors, which speeds code up at runtime by a significant amount. String
eval is not without its issues however - it's difficult to control the scope
it's used in (which determines which variables are in scope inside the eval),
and it's easy to miss compilation errors, since eval catches them and sticks
them in $@ instead. This module attempts to solve these problems. It
provides an eval_closure function, which evals a string in a clean
environment, other than a fixed list of specified variables. Compilation
errors are rethrown automatically."
)
(
license
(
package-license
perl
))))
(
define-public
perl-exporter-lite
(
define-public
perl-exporter-lite
(
package
(
package
(
name
"perl-exporter-lite"
)
(
name
"perl-exporter-lite"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment