Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
8cc9e7f9
Commit
8cc9e7f9
authored
11 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add CHICKEN.
* gnu/packages/scheme.scm (chicken): New variable.
parent
25c93676
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/scheme.scm
+41
-0
41 additions, 0 deletions
gnu/packages/scheme.scm
with
41 additions
and
0 deletions
gnu/packages/scheme.scm
+
41
−
0
View file @
8cc9e7f9
...
@@ -255,3 +255,44 @@ (define-public hop
...
@@ -255,3 +255,44 @@ (define-public hop
...), ubiquitous and house automation (SmartPhones, personal appliance),
...), ubiquitous and house automation (SmartPhones, personal appliance),
mashups, office (web agendas, mail clients, ...), etc."
)
mashups, office (web agendas, mail clients, ...), etc."
)
(
license
gpl2+
)))
(
license
gpl2+
)))
(
define-public
chicken
(
package
(
name
"chicken"
)
(
version
"4.8.0.3"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://code.call-cc.org/releases/4.8.0/chicken-"
version
".tar.gz"
))
(
sha256
(
base32
"1hwrnc2dhgbnz3mlpcb4qvg76kwsfzqylw24gxyy91jmygk1853a"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:modules
((
guix
build
gnu-build-system
)
(
guix
build
utils
)
(
srfi
srfi-1
))
;; No `configure' script; run "make check" after "make install" as
;; prescribed by README.
#
:phases
(
alist-cons-after
'install
'check
(
assoc-ref
%standard-phases
'check
)
(
fold
alist-delete
%standard-phases
'
(
configure
check
)))
#
:make-flags
(
let
((
out
(
assoc-ref
%outputs
"out"
)))
(
list
"PLATFORM=linux"
(
string-append
"PREFIX="
out
)
(
string-append
"VARDIR="
out
"/var/lib"
)))
;; Parallel builds are not supported, as noted in README.
#
:parallel-build?
#f
))
(
home-page
"http://www.call-cc.org/"
)
(
synopsis
"R5RS Scheme implementation that compiles native code via C"
)
(
description
"CHICKEN is a compiler for the Scheme programming language. CHICKEN
produces portable and efficient C, supports almost all of the R5RS Scheme
language standard, and includes many enhancements and extensions. CHICKEN
runs on Linux, MacOS X, Windows, and many Unix flavours."
)
(
license
bsd-3
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment