Skip to content
Snippets Groups Projects
Commit 8d9872b5 authored by Marek Benc's avatar Marek Benc Committed by Ludovic Courtès
Browse files

gnu: Add jbig2dec


* gnu/packages/image.scm (jbig2dec): New variable.
* gnu/packages/patches/jbig2dec-ignore-testtest.patch: New file.
* gnu-system.am (dist_patch_DATA): Added the above patch.

Signed-off-by: default avatarLudovic Courtès <ludo@gnu.org>
parent a023cca8
No related branches found
No related tags found
No related merge requests found
......@@ -350,6 +350,7 @@ dist_patch_DATA = \
gnu/packages/patches/hop-bigloo-4.0b.patch \
gnu/packages/patches/icu4c-test-date-format.patch \
gnu/packages/patches/inkscape-stray-comma.patch \
gnu/packages/patches/jbig2dec-ignore-testtest.patch \
gnu/packages/patches/kmod-module-directory.patch \
gnu/packages/patches/libbonobo-activation-test-race.patch \
gnu/packages/patches/libevent-dns-tests.patch \
......
......@@ -156,3 +156,32 @@ (define-public libwmf
;; 'COPYING' is the GPLv2, but file headers say LGPLv2.0+.
(license license:lgpl2.0+)))
(define-public jbig2dec
(package
(name "jbig2dec")
(version "0.11")
(source
(origin
(method url-fetch)
(uri ;; The link on the homepage is dead.
(string-append "http://distfiles.gentoo.org/distfiles/" name "-"
version ".tar.gz"))
(sha256
(base32 "1ffhgmf2fqzk0h4k736pp06z7q5y4x41fg844bd6a9vgncq86bby"))
(patches (list (search-patch "jbig2dec-ignore-testtest.patch")))))
(build-system gnu-build-system)
(synopsis "Decoder of the JBIG2 image compression format")
(description
"JBIG2 is designed for lossy or lossless encoding of 'bilevel'
(1-bit monochrome) images at moderately high resolution, and in
particular scanned paper documents. In this domain it is very
efficient, offering compression ratios on the order of 100:1.
This is a decoder only implementation, and currently is in the alpha
stage, meaning it doesn't completely work yet. However, it is
maintaining parity with available encoders, so it is useful for real
work.")
(home-page "http://jbig2dec.sourceforge.net/")
(license license:gpl2+)))
Do not run the "testtest script", it doesn't seem to do anything and reports
failiute. TODO: Actually fix the test instead of ignoring it.
--- a/Makefile.in 2010-02-02 20:13:56.000000000 +0100
+++ b/Makefile.in 2014-09-13 17:50:10.957816767 +0200
@@ -181,7 +181,7 @@
MAINTAINERCLEANFILES = config_types.h.in
-TESTS = test_sha1 test_jbig2dec.py test_huffman test_arith
+TESTS = test_sha1 test_huffman test_arith
test_sha1_SOURCES = sha1.c sha1.h
test_sha1_CFLAGS = -DTEST
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment