Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
8dc797fa
Commit
8dc797fa
authored
9 years ago
by
Ben Woodcroft
Committed by
Ricardo Wurmus
9 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add aragorn.
* gnu/packages/bioinformatics.scm (aragorn): New variable.
parent
5ff0edae
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/bioinformatics.scm
+48
-0
48 additions, 0 deletions
gnu/packages/bioinformatics.scm
with
48 additions
and
0 deletions
gnu/packages/bioinformatics.scm
+
48
−
0
View file @
8dc797fa
...
...
@@ -54,6 +54,54 @@ (define-module (gnu packages bioinformatics)
#
:use-module
(
gnu
packages
xml
)
#
:use-module
(
gnu
packages
zip
))
(
define-public
aragorn
(
package
(
name
"aragorn"
)
(
version
"1.2.36"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://mbio-serv2.mbioekol.lu.se/ARAGORN/Downloads/aragorn"
version
".tgz"
))
(
sha256
(
base32
"1dg7jlz1qpqy88igjxd6ncs11ccsirb36qv1z01a0np4i4jh61mb"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:tests?
#f
; there are no tests
#
:phases
(
modify-phases
%standard-phases
(
delete
'configure
)
(
replace
'build
(
lambda
_
(
zero?
(
system*
"gcc"
"-O3"
"-ffast-math"
"-finline-functions"
"-o"
"aragorn"
(
string-append
"aragorn"
,
version
".c"
)))))
(
replace
'install
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let*
((
out
(
assoc-ref
outputs
"out"
))
(
bin
(
string-append
out
"/bin"
))
(
man
(
string-append
out
"/share/man/man1"
)))
(
mkdir-p
bin
)
(
copy-file
"aragorn"
(
string-append
bin
"/aragorn"
))
(
mkdir-p
man
)
(
copy-file
"aragorn.1"
(
string-append
man
"/aragorn.1"
)))
#t
)))))
(
home-page
"http://mbio-serv2.mbioekol.lu.se/ARAGORN"
)
(
synopsis
"Detect tRNA, mtRNA and tmRNA genes in nucleotide sequences"
)
(
description
"Aragorn identifies transfer RNA, mitochondrial RNA and
transfer-messenger RNA from nucleotide sequences, based on homology to known
tRNA consensus sequences and RNA structure. It also outputs the secondary
structure of the predicted RNA."
)
(
license
license:gpl2
)))
(
define-public
bamtools
(
package
(
name
"bamtools"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment