Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
93c5c6d1
Unverified
Commit
93c5c6d1
authored
5 years ago
by
Rutger Helling
Browse files
Options
Downloads
Patches
Plain Diff
gnu: spirv-headers: Update to 1.3.7.
* gnu/packages/vulkan.scm (spirv-headers): Update to 1.3.7.
parent
b2e417f3
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/vulkan.scm
+30
-34
30 additions, 34 deletions
gnu/packages/vulkan.scm
with
30 additions
and
34 deletions
gnu/packages/vulkan.scm
+
30
−
34
View file @
93c5c6d1
...
@@ -41,37 +41,33 @@ (define-module (gnu packages vulkan)
...
@@ -41,37 +41,33 @@ (define-module (gnu packages vulkan)
#
:use-module
(
gnu
packages
xorg
))
#
:use-module
(
gnu
packages
xorg
))
(
define-public
spirv-headers
(
define-public
spirv-headers
;; Keep updated in accordance with
(
package
;; https://github.com/google/shaderc/blob/known-good/known_good.json
(
name
"spirv-headers"
)
(
let
((
commit
"8bea0a266ac9b718aa0818d9e3a47c0b77c2cb23"
)
(
version
"1.3.7"
)
(
revision
"4"
))
(
source
(
package
(
origin
(
name
"spirv-headers"
)
(
method
git-fetch
)
(
version
(
string-append
"0.0-"
revision
"."
(
string-take
commit
9
)))
(
uri
(
git-reference
(
source
(
url
"https://github.com/KhronosGroup/SPIRV-Headers"
)
(
origin
(
commit
version
)))
(
method
git-fetch
)
(
sha256
(
uri
(
git-reference
(
base32
(
url
"https://github.com/KhronosGroup/SPIRV-Headers"
)
"0m56smanfcczjfif4yfcqhjj4d4sc088kwg6dgia8fwdsjavdm4d"
))
(
commit
commit
)))
(
file-name
(
string-append
name
"-"
version
"-checkout"
))))
(
sha256
(
build-system
cmake-build-system
)
(
base32
(
arguments
"01qyjghjz42hmyw9111zz20a1paf37ps39p4xbj8abjba65d8lqx"
))
`
(
#
:tests?
#f
;; No tests
(
file-name
(
string-append
name
"-"
version
"-checkout"
))))
#
:phases
(
modify-phases
%standard-phases
(
build-system
cmake-build-system
)
(
replace
'install
(
arguments
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
`
(
#
:tests?
#f
;; No tests
(
invoke
"cmake"
"-E"
"copy_directory"
#
:phases
(
modify-phases
%standard-phases
"../source/include/spirv"
(
replace
'install
(
string-append
(
assoc-ref
outputs
"out"
)
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
"/include/spirv"
)))))))
(
invoke
"cmake"
"-E"
"copy_directory"
(
home-page
"https://github.com/KhronosGroup/SPIRV-Headers"
)
"../source/include/spirv"
(
synopsis
"Machine-readable files from the SPIR-V Registry"
)
(
string-append
(
assoc-ref
outputs
"out"
)
(
description
"/include/spirv"
)))))))
"SPIRV-Headers is a repository containing machine-readable files from
(
home-page
"https://github.com/KhronosGroup/SPIRV-Headers"
)
(
synopsis
"Machine-readable files from the SPIR-V Registry"
)
(
description
"SPIRV-Headers is a repository containing machine-readable files from
the SPIR-V Registry. This includes:
the SPIR-V Registry. This includes:
@itemize
@itemize
@item Header files for various languages.
@item Header files for various languages.
...
@@ -79,9 +75,9 @@ (define-public spirv-headers
...
@@ -79,9 +75,9 @@ (define-public spirv-headers
and for the GLSL.std.450 extended instruction set.
and for the GLSL.std.450 extended instruction set.
@item The XML registry file.
@item The XML registry file.
@end itemize\n"
)
@end itemize\n"
)
(
license
(
license:x11-style
(
license
(
license:x11-style
(
string-append
"https://github.com/KhronosGroup/SPIRV-Headers/blob/"
(
string-append
"https://github.com/KhronosGroup/SPIRV-Headers/blob/"
commit
"/LICENSE"
)))))
)
version
"/LICENSE"
)))))
(
define-public
spirv-tools
(
define-public
spirv-tools
(
package
(
package
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment