Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
951581a2
Unverified
Commit
951581a2
authored
8 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add ingen.
* gnu/packages/music.scm (ingen): New variable.
parent
f91d0d08
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/music.scm
+85
-0
85 additions, 0 deletions
gnu/packages/music.scm
with
85 additions
and
0 deletions
gnu/packages/music.scm
+
85
−
0
View file @
951581a2
...
@@ -2481,6 +2481,91 @@ (define-public mod-utilities
...
@@ -2481,6 +2481,91 @@ (define-public mod-utilities
plugins, a switch trigger, a toggle switch, and a peakmeter."
)
plugins, a switch trigger, a toggle switch, and a peakmeter."
)
(
license
license:gpl2+
))))
(
license
license:gpl2+
))))
(
define-public
ingen
(
let
((
commit
"fd147d0b888090bfb897505852c1f25dbdf77e18"
)
(
revision
"1"
))
(
package
(
name
"ingen"
)
(
version
(
string-append
"0.0.0-"
revision
"."
(
string-take
commit
9
)))
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
"http://git.drobilla.net/ingen.git"
)
(
commit
commit
)))
(
file-name
(
string-append
name
"-"
version
"-checkout"
))
(
sha256
(
base32
"1qmg79962my82c43vyrv5sxbqci9c7gc2s9bwaaqd0fcf08xcz1z"
))))
(
build-system
waf-build-system
)
(
arguments
`
(
#
:tests?
#f
; no "check" target
#
:configure-flags
(
list
"--no-webkit"
)
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'patch-wscript
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let
((
out
(
assoc-ref
outputs
"out"
)))
(
substitute*
"wscript"
;; FIXME: Our version of lv2specgen.py does not behave as
;; expected. Maybe this requires a development version of
;; LV2.
((
"lv2specgen.py"
)
"touch ingen.lv2/ingen.html; echo"
)
;; Add libraries to RUNPATH.
((
"^(.+)target.*= 'src/ingen/ingen',"
line
prefix
)
(
string-append
prefix
"linkflags=[\"-Wl,-rpath="
out
"/lib"
"\"],"
line
)))
(
substitute*
'
(
"src/wscript"
"src/server/wscript"
)
;; Add libraries to RUNPATH.
((
"bld.env.PTHREAD_LINKFLAGS"
line
)
(
string-append
line
" + [\"-Wl,-rpath="
out
"/lib"
"\"]"
)))
(
substitute*
"src/client/wscript"
;; Add libraries to RUNPATH.
((
"^(.+)target.*= 'ingen_client',"
line
prefix
)
(
string-append
prefix
"linkflags=[\"-Wl,-rpath="
out
"/lib"
"\"],"
line
)))
(
substitute*
"src/gui/wscript"
;; Add libraries to RUNPATH.
((
"^(.+)target.* = 'ingen_gui.*"
line
prefix
)
(
string-append
prefix
"linkflags=[\"-Wl,-rpath="
out
"/lib"
"\"],"
line
))))
#t
)))))
(
inputs
`
((
"boost"
,
boost
)
(
"python-rdflib"
,
python-rdflib
)
(
"python"
,
python
)
(
"jack"
,
jack-1
)
(
"lv2"
,
lv2
)
(
"lilv"
,
lilv
)
(
"raul"
,
raul-devel
)
(
"ganv"
,
ganv-devel
)
(
"suil"
,
suil
)
(
"serd"
,
serd
)
(
"sord"
,
sord
)
(
"sratom"
,
sratom
)
(
"gtkmm"
,
gtkmm-2
)))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"python-pygments"
,
python-pygments
)))
(
home-page
"http://drobilla.net/software/ingen"
)
(
synopsis
"Modular audio processing system"
)
(
description
"Ingen is a modular audio processing system for JACK and
LV2 based systems. Ingen is built around LV2 technology and a strict
separation of engine from user interface. The engine is controlled
exclusively through a protocol, and can execute as a headless process, with an
in-process GUI, or as an LV2 plugin. The GUI can run as a program which
communicates over a Unix or TCP/IP socket, or as an embeddable LV2 GUI which
communicates via LV2 ports. Any saved Ingen graph can be loaded as an LV2
plugin on any system where Ingen is installed. This allows users to visually
develop custom plugins for use in other applications without programming."
)
(
license
license:agpl3+
))))
(
define-public
python-discogs-client
(
define-public
python-discogs-client
(
package
(
package
(
name
"python-discogs-client"
)
(
name
"python-discogs-client"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment