Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
95283f3f
Commit
95283f3f
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add gerbv.
* gnu/packages/engineering.scm (gerbv): New variable.
parent
97f70018
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/engineering.scm
+48
-0
48 additions, 0 deletions
gnu/packages/engineering.scm
with
48 additions
and
0 deletions
gnu/packages/engineering.scm
+
48
−
0
View file @
95283f3f
...
...
@@ -28,6 +28,7 @@ (define-module (gnu packages engineering)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
bison
)
#
:use-module
(
gnu
packages
boost
)
...
...
@@ -35,6 +36,7 @@ (define-module (gnu packages engineering)
#
:use-module
(
gnu
packages
flex
)
#
:use-module
(
gnu
packages
fontutils
)
#
:use-module
(
gnu
packages
gd
)
#
:use-module
(
gnu
packages
gettext
)
#
:use-module
(
gnu
packages
ghostscript
)
#
:use-module
(
gnu
packages
gl
)
#
:use-module
(
gnu
packages
glib
)
...
...
@@ -364,3 +366,49 @@ (define-public fasthenry
"Fasthenry is an inductance extraction program based on a
multipole-accelerated algorithm."
)
(
license
(
license:non-copyleft
#f
"See induct.c."
))))
(
define-public
gerbv
(
package
(
name
"gerbv"
)
(
version
"2.6.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/gerbv/gerbv/gerbv-"
version
"/gerbv-"
version
".tar.gz"
))
(
sha256
(
base32
"0v6ry0mxi5qym4z0y0lpblxsw9dfjpgxs4c4v2ngg7yw4b3a59ks"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
(
add-before
'configure
'autoconf
(
lambda
_
;; Build rules contain references to Russian translation, but the
;; needed files are missing; see
;; http://sourceforge.net/p/gerbv/bugs/174/
(
delete-file
"po/LINGUAS"
)
(
substitute*
"man/Makefile.am"
((
"PO_FILES= gerbv.ru.1.in.po"
)
""
)
((
"man_MANS = gerbv.1 gerbv.ru.1"
)
"man_MANS = gerbv.1"
))
(
zero?
(
system*
"autoreconf"
"-vfi"
)))))))
(
native-inputs
`
((
"autoconf"
,
autoconf
)
(
"automake"
,
automake
)
(
"libtool"
,
libtool
)
(
"gettext"
,
gnu-gettext
)
(
"po4a"
,
po4a
)
(
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"cairo"
,
cairo
)
(
"gtk"
,
gtk+-2
)
(
"desktop-file-utils"
,
desktop-file-utils
)))
(
home-page
"http://gerbv.geda-project.org/"
)
(
synopsis
"Gerber file viewer"
)
(
description
"Gerbv is a viewer for files in the Gerber format (RS-274X only), which
is commonly used to represent printed circuit board (PCB) layouts. Gerbv lets
you load several files on top of each other, do measurements on the displayed
image, etc. Besides viewing Gerbers, you may also view Excellon drill files
as well as pick-place files."
)
(
license
license:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment