Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
9ceb630c
Commit
9ceb630c
authored
11 years ago
by
Cyril Roelandt
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add gobject-introspection.
* gnu/packages/glib.scm (gobject-introspection): New variable.
parent
ecfb6993
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/glib.scm
+46
-0
46 additions, 0 deletions
gnu/packages/glib.scm
with
46 additions
and
0 deletions
gnu/packages/glib.scm
+
46
−
0
View file @
9ceb630c
...
...
@@ -26,9 +26,12 @@ (define-module (gnu packages glib)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
bison
)
#
:use-module
(
gnu
packages
compression
)
#
:use-module
(
gnu
packages
flex
)
#
:use-module
((
gnu
packages
gettext
)
#
:renamer
(
symbol-prefix-proc
'guix:
))
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
libffi
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
pkg-config
)
...
...
@@ -171,6 +174,49 @@ (define glib
(
home-page
"http://developer.gnome.org/glib/"
)
(
license
license:lgpl2
.
0
+
)))
; some files are under lgpl2.1+
(
define-public
gobject-introspection
(
package
(
name
"gobject-introspection"
)
(
version
"1.38.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://ftp.gnome.org/pub/GNOME/sources/"
"gobject-introspection/"
(
substring
version
0
(
string-rindex
version
#\.
))
"/gobject-introspection-"
version
".tar.xz"
))
(
sha256
(
base32
"0wvxyvgajmms2bb6k3pf1rdpnd79xdxamykzvxzmcyn1ag9yax9m"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"bison"
,
bison
)
(
"cairo"
,
cairo
)
(
"flex"
,
flex
)
(
"glib"
,
glib
)
(
"libffi"
,
libffi
)
(
"pkg-config"
,
pkg-config
)
(
"python-2"
,
python-2
)))
(
arguments
`
(
#
:phases
(
alist-replace
'configure
(
lambda*
(
#
:key
#
:allow-other-keys
#
:rest
args
)
(
let
((
configure
(
assoc-ref
%standard-phases
'configure
)))
;; giscanner/sourcescanner.py looks for 'CC', let's set it here.
(
setenv
"CC"
"gcc"
)
(
apply
configure
args
)))
%standard-phases
)))
(
home-page
"https://wiki.gnome.org/GObjectIntrospection"
)
(
synopsis
"Generate interface introspection data for GObject libraries"
)
(
description
"GObject introspection is a middleware layer between C libraries (using
GObject) and language bindings. The C library can be scanned at compile time
and generate a metadata file, in addition to the actual native C library. Then
at runtime, language bindings can read this metadata and automatically provide
bindings to call into the C library."
)
; Some bits are distributed under the LGPL2+, others under the GPL2+
(
license
license:gpl2+
)))
(
define
intltool
(
package
(
name
"intltool"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment