Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
a3dbfbbd
Unverified
Commit
a3dbfbbd
authored
6 years ago
by
Christopher Baines
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add ruby-rails.
* gnu/packages/rails.scm (ruby-rails): New variable.
parent
07884945
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/rails.scm
+53
-0
53 additions, 0 deletions
gnu/packages/rails.scm
with
53 additions
and
0 deletions
gnu/packages/rails.scm
+
53
−
0
View file @
a3dbfbbd
...
@@ -412,3 +412,56 @@ (define-public ruby-sprockets-rails
...
@@ -412,3 +412,56 @@ (define-public ruby-sprockets-rails
(
home-page
(
home-page
"https://github.com/rails/sprockets-rails"
)
"https://github.com/rails/sprockets-rails"
)
(
license
license:expat
)))
(
license
license:expat
)))
(
define-public
ruby-rails
(
package
(
name
"ruby-rails"
)
(
version
"5.2.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
rubygems-uri
"rails"
version
))
(
sha256
(
base32
"1m9cszds68dsiycciiayd3c9g90s2yzn1izkr3gpgqkfw6dmvzyr"
))))
(
build-system
ruby-build-system
)
(
arguments
'
(
#
:phases
(
modify-phases
%standard-phases
;; This gem acts as glue between the gems that actually make up
;; Rails. The important thing to check is that the gemspec matches up
;; with the Guix packages and Rubygems can successfully activate the
;; Rails gem.
;;
;; The following check phase tests this.
(
delete
'check
)
(
add-after
'install
'check
(
lambda*
(
#
:key
tests?
outputs
#
:allow-other-keys
)
(
setenv
"GEM_PATH"
(
string-append
(
getenv
"GEM_PATH"
)
":"
(
assoc-ref
outputs
"out"
)
"/lib/ruby/vendor_ruby"
))
(
when
tests?
(
invoke
"ruby"
"-e"
"gem 'rails'"
))
#t
)))))
(
propagated-inputs
`
((
"ruby-activesupport"
,
ruby-activesupport
)
(
"ruby-actionpack"
,
ruby-actionpack
)
(
"ruby-actionview"
,
ruby-actionview
)
(
"ruby-activemodel"
,
ruby-activemodel
)
(
"ruby-activerecord"
,
ruby-activerecord
)
(
"ruby-actionmailer"
,
ruby-actionmailer
)
(
"ruby-activejob"
,
ruby-activejob
)
(
"ruby-actioncable"
,
ruby-actioncable
)
(
"ruby-activestorage"
,
ruby-activestorage
)
(
"ruby-railties"
,
ruby-railties
)
(
"bundler"
,
bundler
)
(
"ruby-sprockets-rails"
,
ruby-sprockets-rails
)))
(
synopsis
"Full-stack web framework optimized for programmer happiness"
)
(
description
"Ruby on Rails is a full-stack web framework optimized for programmer
happiness and sustainable productivity. It encourages beautiful code by
favoring convention over configuration."
)
(
home-page
"https://rubyonrails.org/"
)
(
license
license:expat
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment