Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
ab715ec9
Commit
ab715ec9
authored
9 years ago
by
Eric Bavier
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add ghc-test-framework-quickcheck2.
* gnu/packages/haskell.scm (ghc-test-framework-quickcheck2): New variable.
parent
e1c1b71c
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/haskell.scm
+33
-0
33 additions, 0 deletions
gnu/packages/haskell.scm
with
33 additions
and
0 deletions
gnu/packages/haskell.scm
+
33
−
0
View file @
ab715ec9
...
@@ -1779,6 +1779,39 @@ (define-public ghc-test-framework-hunit
...
@@ -1779,6 +1779,39 @@ (define-public ghc-test-framework-hunit
"This package provides HUnit support for the test-framework package."
)
"This package provides HUnit support for the test-framework package."
)
(
license
bsd-3
)))
(
license
bsd-3
)))
(
define-public
ghc-test-framework-quickcheck2
(
package
(
name
"ghc-test-framework-quickcheck2"
)
(
version
"0.3.0.3"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://hackage.haskell.org/package/"
"test-framework-quickcheck2/"
"test-framework-quickcheck2-"
version
".tar.gz"
))
(
sha256
(
base32
"12p1zwrsz35r3j5gzbvixz9z1h5643rhihf5gqznmc991krwd5nc"
))
(
modules
'
((
guix
build
utils
)))
(
snippet
;; The Hackage page and the cabal file linked there for this package
;; both list 2.9 as the upper version limit, but the source tarball
;; specifies 2.8. Assume the Hackage page is correct.
'
(
substitute*
"test-framework-quickcheck2.cabal"
((
"QuickCheck >= 2.4 && < 2.8"
)
"QuickCheck >= 2.4 && < 2.9"
)))))
(
build-system
haskell-build-system
)
(
propagated-inputs
`
((
"ghc-extensible-exceptions"
,
ghc-extensible-exceptions
)
(
"ghc-quickcheck"
,
ghc-quickcheck
)
(
"ghc-random"
,
ghc-random
)
(
"ghc-test-framework"
,
ghc-test-framework
)))
(
home-page
"https://batterseapower.github.io/test-framework/"
)
(
synopsis
"QuickCheck2 support for test-framework"
)
(
description
"This packages provides QuickCheck2 support for the test-framework
package."
)
(
license
bsd-3
)))
(
define-public
ghc-tf-random
(
define-public
ghc-tf-random
(
package
(
package
(
name
"ghc-tf-random"
)
(
name
"ghc-tf-random"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment