Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
acad932e
Unverified
Commit
acad932e
authored
6 years ago
by
Pierre Neidhardt
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add sbcl-next.
* gnu/packages/web-browsers.scm (sbcl-next): New variable.
parent
18974c1e
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/web-browsers.scm
+68
-1
68 additions, 1 deletion
gnu/packages/web-browsers.scm
with
68 additions
and
1 deletion
gnu/packages/web-browsers.scm
+
68
−
1
View file @
acad932e
...
...
@@ -37,6 +37,7 @@ (define-module (gnu packages web-browsers)
#
:use-module
(
gnu
packages
gnupg
)
#
:use-module
(
gnu
packages
libevent
)
#
:use-module
(
gnu
packages
libidn
)
#
:use-module
(
gnu
packages
lisp
)
#
:use-module
(
gnu
packages
lua
)
#
:use-module
(
gnu
packages
gnome
)
#
:use-module
(
gnu
packages
ncurses
)
...
...
@@ -53,7 +54,8 @@ (define-module (gnu packages web-browsers)
#
:use-module
(
guix
git-download
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
glib-or-gtk
)
#
:use-module
(
guix
build-system
python
))
#
:use-module
(
guix
build-system
python
)
#
:use-module
(
guix
build-system
asdf
))
(
define-public
dillo
(
package
...
...
@@ -401,3 +403,68 @@ (define-public next-gtk-webkit
key-bindings, is fully configurable and extensible in Lisp, and has powerful
features for productive professionals."
)
(
license
license:bsd-3
))))
(
define-public
sbcl-next
(
package
(
inherit
next-gtk-webkit
)
(
name
"sbcl-next"
)
(
build-system
asdf-build-system/sbcl
)
(
outputs
'
(
"out"
"lib"
))
(
arguments
`
(
#
:tests?
#f
; no tests
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'patch-platform-port-path
(
lambda*
(
#
:key
inputs
#
:allow-other-keys
)
(
substitute*
"source/ports/gtk-webkit.lisp"
((
"\"next-gtk-webkit\""
)
(
string-append
"\""
(
assoc-ref
inputs
"next-gtk-webkit"
)
"/bin/next-gtk-webkit\""
)))))
(
add-before
'cleanup
'move-bundle
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
define
lib
(
assoc-ref
outputs
"lib"
))
(
define
actual-fasl
(
string-append
lib
"/lib/sbcl/next.fasl"
))
(
define
expected-fasl
(
string-append
lib
"/lib/sbcl/next--system.fasl"
))
(
pk
actual-fasl
)
(
pk
expected-fasl
)
(
copy-file
actual-fasl
expected-fasl
)
#t
))
(
add-after
'create-symlinks
'build-program
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
build-program
(
string-append
(
assoc-ref
outputs
"out"
)
"/bin/next"
)
outputs
#
:entry-program
'
((
next:start-with-port
)
0
))))
(
add-before
'build
'install-assets
;; Since the ASDF build system generates a new .asd with a
;; possibly suffixed and thus illegal version number, assets
;; should not be installed after the 'build phase or else
;; the illegal version will result in NIL in the .desktop
;; file.
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
invoke
"make"
"install-assets"
(
string-append
"PREFIX="
(
assoc-ref
outputs
"out"
))))))))
(
inputs
`
((
"next-gtk-webkit"
,
next-gtk-webkit
)
;; Lisp libraries:
(
"trivial-features"
,
sbcl-trivial-features
)
(
"alexandria"
,
sbcl-alexandria
)
(
"cl-strings"
,
sbcl-cl-strings
)
(
"cl-string-match"
,
sbcl-cl-string-match
)
(
"puri"
,
sbcl-puri
)
(
"queues.simple-queue"
,
sbcl-queues
.
simple-queue
)
(
"sqlite"
,
sbcl-cl-sqlite
)
(
"parenscript"
,
sbcl-parenscript
)
(
"cl-json"
,
sbcl-cl-json
)
(
"swank"
,
sbcl-slime-swank
)
(
"cl-markup"
,
sbcl-cl-markup
)
(
"cl-css"
,
sbcl-cl-css
)
(
"usocket"
,
sbcl-usocket
)
(
"bordeaux-threads"
,
sbcl-bordeaux-threads
)
(
"s-xml-rpc"
,
sbcl-s-xml-rpc
)
(
"unix-opts"
,
sbcl-unix-opts
)))
(
synopsis
"Infinitely extensible web-browser (with Lisp development files)"
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment