Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
b3df4d7e
Unverified
Commit
b3df4d7e
authored
8 years ago
by
Marius Bakke
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add speech-dispatcher.
* gnu/packages/speech.scm (speech-dispatcher): New variable.
parent
b58691fa
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/speech.scm
+44
-1
44 additions, 1 deletion
gnu/packages/speech.scm
with
44 additions
and
1 deletion
gnu/packages/speech.scm
+
44
−
1
View file @
b3df4d7e
;;; GNU Guix --- Functional package management for GNU
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -22,7 +23,12 @@ (define-module (gnu packages speech)
...
@@ -22,7 +23,12 @@ (define-module (gnu packages speech)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
gcc
))
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
gcc
)
#
:use-module
(
gnu
packages
glib
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
pulseaudio
)
#
:use-module
(
gnu
packages
textutils
))
(
define-public
mitlm
(
define-public
mitlm
(
package
(
package
...
@@ -49,3 +55,40 @@ (define-public mitlm
...
@@ -49,3 +55,40 @@ (define-public mitlm
efficiency through the use of a compact vector representation of n-grams."
)
efficiency through the use of a compact vector representation of n-grams."
)
(
home-page
"https://github.com/mitlm/mitlm"
)
(
home-page
"https://github.com/mitlm/mitlm"
)
(
license
license:expat
)))
(
license
license:expat
)))
(
define-public
speech-dispatcher
(
package
(
name
"speech-dispatcher"
)
(
version
"0.8.5"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://devel.freebsoft.org/pub/"
"projects/speechd/speech-dispatcher-"
version
".tar.gz"
))
(
sha256
(
base32
"18jlxnhlahyi6njc6l6576hfvmzivjjgfjyd2n7vvrvx9inphjrb"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"intltool"
,
intltool
)
(
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"dotconf"
,
dotconf
)
(
"glib"
,
glib
)
(
"libltdl"
,
libltdl
)
(
"libsndfile"
,
libsndfile
)))
(
synopsis
"Common interface to speech synthesizers"
)
(
description
"The Speech Dispatcher project provides a high-level
device independent layer for access to speech synthesis through a simple,
stable and well documented interface."
)
(
home-page
"https://devel.freebsoft.org/speechd"
)
;; The software is distributed under GPL2+, but includes a number
;; of files covered by other licenses.
(
license
(
list
license:gpl2+
license:fdl1
.
2
+
; Most files in doc/ are dual gpl2+/fdl1.2+.
license:lgpl2
.
1
+
license:gpl2
(
license:non-copyleft
;; festival_client.{c,h} carries an expat-style license.
"See src/modules/festival_client.c in the distribution."
)
license:gpl3+
))))
; doc/texinfo.tex -- with TeX exception.
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment