Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
b9d8756b
Commit
b9d8756b
authored
9 years ago
by
Andreas Enge
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add unison.
* gnu/packages/ocaml.scm (unison): New variable.
parent
be78e52c
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ocaml.scm
+44
-0
44 additions, 0 deletions
gnu/packages/ocaml.scm
with
44 additions
and
0 deletions
gnu/packages/ocaml.scm
+
44
−
0
View file @
b9d8756b
;;; GNU Guix --- Functional package management for GNU
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -428,3 +429,46 @@ (define (coq-prog name)
...
@@ -428,3 +429,46 @@ (define (coq-prog name)
assistant to write formal mathematical proofs using a variety of theorem
assistant to write formal mathematical proofs using a variety of theorem
provers."
)
provers."
)
(
license
gpl2+
)))
(
license
gpl2+
)))
(
define-public
unison
(
package
(
name
"unison"
)
(
version
"2.48.3"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://www.seas.upenn.edu/~bcpierce/unison/"
"download/releases/stable/unison-"
version
".tar.gz"
))
(
sha256
(
base32
"10sln52rnnsj213jy3166m0q97qpwnrwl6mm529xfy10x3xkq3gl"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"ocaml"
,
ocaml
)))
(
arguments
`
(
#
:parallel-build?
#f
#
:parallel-tests?
#f
#
:test-target
"selftest"
#
:tests?
#f
; Tests require writing to $HOME.
; If some $HOME is provided, they fail with the message
; "Fatal error: Skipping some tests -- remove me!"
#
:phases
(
modify-phases
%standard-phases
(
delete
'configure
)
(
add-before
'install
'prepare-install
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let*
((
out
(
assoc-ref
outputs
"out"
))
(
bin
(
string-append
out
"/bin"
)))
(
mkdir-p
bin
)
(
setenv
"HOME"
out
)
; forces correct INSTALLDIR in Makefile
#t
))))))
(
home-page
"https://www.cis.upenn.edu/~bcpierce/unison/"
)
(
synopsis
"File synchronizer"
)
(
description
"Unison is a file-synchronization tool. It allows two replicas of
a collection of files and directories to be stored on different hosts
(or different disks on the same host), modified separately, and then
brought up to date by propagating the changes in each replica
to the other."
)
(
license
gpl3+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment