Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
ba1be533
Unverified
Commit
ba1be533
authored
8 years ago
by
Ben Woodcroft
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add ocaml-gsl.
* gnu/packages/maths.scm (ocaml-gsl): New variable.
parent
91df9eae
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/maths.scm
+27
-0
27 additions, 0 deletions
gnu/packages/maths.scm
with
27 additions
and
0 deletions
gnu/packages/maths.scm
+
27
−
0
View file @
ba1be533
...
...
@@ -17,6 +17,7 @@
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -44,6 +45,7 @@ (define-module (gnu packages maths)
#
:use-module
(
guix
build
utils
)
#
:use-module
(
guix
build-system
cmake
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
ocaml
)
#
:use-module
(
guix
build-system
r
)
#
:use-module
(
gnu
packages
algebra
)
#
:use-module
(
gnu
packages
bison
)
...
...
@@ -77,6 +79,7 @@ (define-module (gnu packages maths)
#
:use-module
(
gnu
packages
mpi
)
#
:use-module
(
gnu
packages
multiprecision
)
#
:use-module
(
gnu
packages
netpbm
)
#
:use-module
(
gnu
packages
ocaml
)
#
:use-module
(
gnu
packages
pcre
)
#
:use-module
(
gnu
packages
popt
)
#
:use-module
(
gnu
packages
perl
)
...
...
@@ -277,6 +280,30 @@ (define-public gsl
numbers."
)
(
license
license:gpl3+
)))
(
define-public
ocaml-gsl
(
package
(
name
"ocaml-gsl"
)
(
version
"1.19.3"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/mmottl/gsl-ocaml/releases/download/v"
version
"/gsl-ocaml-"
version
".tar.gz"
))
(
sha256
(
base32
"0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"
))))
(
build-system
ocaml-build-system
)
(
inputs
`
((
"gsl"
,
gsl
)))
(
home-page
"https://mmottl.github.io/gsl-ocaml"
)
(
synopsis
"Bindings to the GNU Scientific Library"
)
(
description
"GSL-OCaml is an interface to the @dfn{GNU scientific library} (GSL) for
the OCaml language."
)
(
license
license:gpl3+
)))
(
define-public
glpk
(
package
(
name
"glpk"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment