Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
bcadaf00
Commit
bcadaf00
authored
9 years ago
by
Ben Woodcroft
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add sortmerna.
* gnu/packages/bioinformatics.scm (sortmerna): New variable.
parent
74273b6f
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/bioinformatics.scm
+43
-0
43 additions, 0 deletions
gnu/packages/bioinformatics.scm
with
43 additions
and
0 deletions
gnu/packages/bioinformatics.scm
+
43
−
0
View file @
bcadaf00
...
...
@@ -3141,6 +3141,49 @@ (define-public snap-aligner
of these reads to align data quickly through a hash-based indexing scheme."
)
(
license
license:asl2
.
0
)))
(
define-public
sortmerna
(
package
(
name
"sortmerna"
)
(
version
"2.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/biocore/sortmerna/archive/"
version
".tar.gz"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"1670a92x1vvkacnvgr2i5xac3ls6lp4pc3n0bccnmllsnymggcf0"
))))
(
build-system
gnu-build-system
)
(
outputs
'
(
"out"
;for binaries
"db"
))
;for sequence databases
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
(
replace
'install
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let*
((
out
(
assoc-ref
outputs
"out"
))
(
bin
(
string-append
out
"/bin"
))
(
db
(
assoc-ref
outputs
"db"
))
(
share
(
string-append
db
"/share/sortmerna/rRNA_databases"
)))
(
install-file
"sortmerna"
bin
)
(
install-file
"indexdb_rna"
bin
)
(
for-each
(
lambda
(
file
)
(
install-file
file
share
))
(
find-files
"rRNA_databases"
".*fasta"
))
#t
))))))
(
home-page
"http://bioinfo.lifl.fr/RNA/sortmerna"
)
(
synopsis
"Biological sequence analysis tool for NGS reads"
)
(
description
"SortMeRNA is a biological sequence analysis tool for filtering, mapping
and operational taxonomic unit (OTU) picking of next generation
sequencing (NGS) reads. The core algorithm is based on approximate seeds and
allows for fast and sensitive analyses of nucleotide sequences. The main
application of SortMeRNA is filtering rRNA from metatranscriptomic data."
)
(
license
license:lgpl3
)))
(
define-public
star
(
package
(
name
"star"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment