Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
c4325f62
Commit
c4325f62
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add idr.
* gnu/packages/bioinformatics.scm (idr): New variable.
parent
f3457e70
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/bioinformatics.scm
+50
-0
50 additions, 0 deletions
gnu/packages/bioinformatics.scm
with
50 additions
and
0 deletions
gnu/packages/bioinformatics.scm
+
50
−
0
View file @
c4325f62
...
...
@@ -1136,6 +1136,56 @@ (define-public htslib
;; the rest is released under the Expat license
(
license
(
list
license:expat
license:bsd-3
))))
(
define-public
idr
(
package
(
name
"idr"
)
(
version
"2.0.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/nboley/idr/archive/"
version
".tar.gz"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"1k3x44biak00aiv3hpm1yd6nn4hhp7n0qnbs3zh2q9sw7qr1qj5r"
))))
(
build-system
python-build-system
)
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
(
add-after
'install
'wrap-program
(
lambda*
(
#
:key
inputs
outputs
#
:allow-other-keys
)
(
let*
((
out
(
assoc-ref
outputs
"out"
))
(
python-version
(
string-take
(
string-take-right
(
assoc-ref
inputs
"python"
)
5
)
3
))
(
path
(
string-join
(
map
(
lambda
(
name
)
(
string-append
(
assoc-ref
inputs
name
)
"/lib/python"
python-version
"/site-packages"
))
'
(
"python-scipy"
"python-numpy"
"python-matplotlib"
))
":"
)))
(
wrap-program
(
string-append
out
"/bin/idr"
)
`
(
"PYTHONPATH"
":"
prefix
(
,path
))))
#t
)))))
(
inputs
`
((
"python-scipy"
,
python-scipy
)
(
"python-numpy"
,
python-numpy
)
(
"python-matplotlib"
,
python-matplotlib
)))
(
native-inputs
`
((
"python-cython"
,
python-cython
)
(
"python-setuptools"
,
python-setuptools
)))
(
home-page
"https://github.com/nboley/idr"
)
(
synopsis
"Tool to measure the irreproducible discovery rate (IDR)"
)
(
description
"The IDR (Irreproducible Discovery Rate) framework is a unified approach
to measure the reproducibility of findings identified from replicate
experiments and provide highly stable thresholds based on reproducibility."
)
(
license
license:gpl3+
)))
(
define-public
macs
(
package
(
name
"macs"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment