Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
c8d969b5
Commit
c8d969b5
authored
9 years ago
by
Pjotr Prins
Committed by
Ricardo Wurmus
9 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add Pfff.
* gnu/packages/textutils.scm (pfff): New variable.
parent
fbbaa4dd
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/textutils.scm
+25
-1
25 additions, 1 deletion
gnu/packages/textutils.scm
with
25 additions
and
1 deletion
gnu/packages/textutils.scm
+
25
−
1
View file @
c8d969b5
;;; GNU Guix --- Functional package management for GNU
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015
, 2016
Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;;
...
@@ -25,6 +25,7 @@ (define-module (gnu packages textutils)
...
@@ -25,6 +25,7 @@ (define-module (gnu packages textutils)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
git-download
)
#
:use-module
(
guix
git-download
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
cmake
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
python
))
#
:use-module
(
gnu
packages
python
))
...
@@ -193,3 +194,26 @@ (define-public libconfig
...
@@ -193,3 +194,26 @@ (define-public libconfig
unlike XML, it is type-aware, so it is not necessary to do string parsing in
unlike XML, it is type-aware, so it is not necessary to do string parsing in
application code."
)
application code."
)
(
license
license:lgpl2
.
1
+
)))
(
license
license:lgpl2
.
1
+
)))
(
define-public
pfff
(
package
(
name
"pfff"
)
(
version
"1.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/pfff/pfff/archive/v"
version
".tar.gz"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"00m553aa277iarxj6dalmklyb64r7ias49bfwzbacsfg8h3kar8m"
))))
(
build-system
cmake-build-system
)
(
home-page
"http://biit.cs.ut.ee/pfff/"
)
(
synopsis
"Probabilistic fast file fingerprinting tool"
)
(
description
"pfff is a tool for calculating a compact digital fingerprint of a file
by sampling randomly from the file instead of reading it in full.
Consequently, the computation has a flat performance characteristic,
correlated with data variation rather than file size. pfff can be as reliable
as existing hashing techniques, with provably negligible risk of collisions."
)
(
license
license:bsd-3
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment