Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
cac8bc38
Commit
cac8bc38
authored
9 years ago
by
Mark H Weaver
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add newt.
* gnu/packages/slang.scm (newt): New variable.
parent
5df2316d
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/slang.scm
+42
-0
42 additions, 0 deletions
gnu/packages/slang.scm
with
42 additions
and
0 deletions
gnu/packages/slang.scm
+
42
−
0
View file @
cac8bc38
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -23,6 +24,8 @@ (define-module (gnu packages slang)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
(
gnu
packages
readline
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
popt
)
#
:use-module
(
gnu
packages
fribidi
)
#
:use-module
(
gnu
packages
compression
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
pcre
))
...
...
@@ -69,3 +72,42 @@ (define-public slang
interpreter, it may also be used in a stand-alone fashion through the use of
slsh, which is part of the S-Lang distribution."
)
(
license
license:gpl2+
)))
(
define-public
newt
(
package
(
name
"newt"
)
(
version
"0.52.18"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://fedorahosted.org/releases/n/e/"
name
"/"
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"07n9f2mqsjfj35wx5ldhvl9sqcjqpcl0g4fdd9mawmny9rihw6vp"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"slang"
,
slang
)
(
"popt"
,
popt
)
(
"fribidi"
,
fribidi
)))
(
arguments
`
(
#
:tests?
#f
; no test suite
#
:configure-flags
;; Set the correct RUNPATH in binaries.
(
list
(
string-append
"LDFLAGS=-Wl,-rpath="
%output
"/lib"
))
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'patch-/usr/bin/install
(
lambda
_
(
substitute*
"po/Makefile"
((
"/usr/bin/install"
)
"install"
))
#t
)))))
(
home-page
"https://fedorahosted.org/newt/"
)
(
synopsis
"Not Erik's Windowing Toolkit - text mode windowing with slang"
)
(
description
"Newt is a windowing toolkit for text mode built from the slang library.
It allows color text mode applications to easily use stackable windows, push
buttons, check boxes, radio buttons, lists, entry fields, labels, and
displayable text. Scrollbars are supported, and forms may be nested to
provide extra functionality."
)
(
license
license:lgpl2
.
0
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment