Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
cc3ac162
Unverified
Commit
cc3ac162
authored
7 years ago
by
Tobias Geerinckx-Rice
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add uthash.
* gnu/packages/datastructures.scm (uthash): New public variable.
parent
8d8d227b
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/datastructures.scm
+55
-0
55 additions, 0 deletions
gnu/packages/datastructures.scm
with
55 additions
and
0 deletions
gnu/packages/datastructures.scm
+
55
−
0
View file @
cc3ac162
...
@@ -116,3 +116,58 @@ (define-public liburcu
...
@@ -116,3 +116,58 @@ (define-public liburcu
based on RCU and lock-free algorithms. These structures include hash tables,
based on RCU and lock-free algorithms. These structures include hash tables,
queues, stacks, and doubly-linked lists."
)
queues, stacks, and doubly-linked lists."
)
(
license
license:lgpl2
.
1
+
)))
(
license
license:lgpl2
.
1
+
)))
(
define-public
uthash
(
package
(
name
"uthash"
)
(
version
"2.0.2"
)
(
source
(
origin
(
method
url-fetch
)
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
uri
(
string-append
"https://github.com/troydhanson/uthash/archive/v"
version
".tar.gz"
))
(
sha256
(
base32
"1la82gdlyl7m8ahdjirigwfh7zjgkc24cvydrqcri0vsvm8iv8rl"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"perl"
,
perl
)))
(
arguments
`
(
#
:make-flags
(
list
"CC=gcc"
)
#
:phases
(
modify-phases
%standard-phases
(
delete
'configure
)
; nothing to configure
(
delete
'build
)
; nothing to build
(
replace
'check
(
lambda*
(
#
:key
make-flags
#
:allow-other-keys
)
(
with-directory-excursion
"tests"
(
zero?
(
apply
system*
"make"
make-flags
)))))
(
replace
'install
;; There is no top-level Makefile to do this for us.
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let*
((
out
(
assoc-ref
outputs
"out"
))
(
doc
(
string-append
out
"/share/doc/"
,
name
))
(
include
(
string-append
out
"/include"
)))
;; Don't install HTML files: they're just the below .txt files
;; dolled up, can be stale, and regeneration requires asciidoc.
(
for-each
(
λ
(
file
)
(
install-file
file
doc
))
(
find-files
"doc"
"\\.txt$"
))
(
for-each
(
λ
(
file
)
(
install-file
file
include
))
(
find-files
"src"
"\\.h$"
))
#t
))))))
(
home-page
"https://troydhanson.github.io/uthash/"
)
(
synopsis
"Hash tables, lists, and other data structures implemented as C macros"
)
(
description
"uthash implements a hash table and a few other basic data structures
as C preprocessor macros. It aims to be minimalistic and efficient: it's
around 1,000 lines of code which, being macros, inline automatically.
Unlike function calls with fixed prototypes, macros operate on untyped
arguments. Thus, they are able to work with any type of structure and key.
Any C structure can be stored in a hash table by adding @code{UT_hash_handle}
to the structure and choosing one or more fields to act as the key."
)
(
license
license:bsd-2
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment