Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
d1c6b097
Unverified
Commit
d1c6b097
authored
4 years ago
by
Marius Bakke
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add packcc.
* gnu/packages/c.scm (packcc): New public variable.
parent
1b8c7d12
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/c.scm
+52
-0
52 additions, 0 deletions
gnu/packages/c.scm
with
52 additions
and
0 deletions
gnu/packages/c.scm
+
52
−
0
View file @
d1c6b097
...
...
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -254,6 +255,57 @@ (define-public libhx
checking casts and more."
)
(
license
license:lgpl2
.
1
+
)))
(
define-public
packcc
(
package
(
name
"packcc"
)
;; We need a few fixes on top of the latest release to prevent test
;; failures in Universal Ctags.
(
version
"1.2.5-19-g58d1b9d"
)
(
home-page
"https://github.com/enechaev/packcc"
)
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
home-page
)
(
commit
(
string-append
"v"
version
))))
(
file-name
(
git-file-name
name
version
))
(
sha256
(
base32
"0biyv835jlk43fvmmd3p8jafs7k2iw9qlaj37hvsl604ai6rd5aj"
))))
(
build-system
gnu-build-system
)
(
arguments
'
(
#
:tests?
#f
;no tests
#
:make-flags
'
(
"-DUSE_SYSTEM_STRNLEN=1"
)
#
:phases
(
modify-phases
%standard-phases
;; The project consists of a single source file and has
;; no actual build system, so we need to do it manually.
(
delete
'configure
)
(
replace
'build
(
lambda*
(
#
:key
make-flags
#
:allow-other-keys
)
(
apply
invoke
"gcc"
"-o"
"packcc"
"packcc.c"
make-flags
)))
(
replace
'install
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let
((
out
(
assoc-ref
outputs
"out"
)))
(
install-file
"packcc"
(
string-append
out
"/bin"
))
(
install-file
"README.md"
(
string-append
out
"/share/doc/packcc"
))
#t
))))))
(
synopsis
"Packrat parser generator for C"
)
(
description
"PackCC is a packrat parser generator for the C programming language.
Its main features are:
@itemize
@item Generates a parser in C from a grammar described in a PEG.
@item Gives your parser great efficiency by packrat parsing.
@item Supports direct and indirect left-recursive grammar rules.
@end itemize
The grammar of your parser can be described in a @acronym{PEG, Parsing
Expression Grammar}. The PEG is a top-down parsing language, and is similar
to the regular-expression grammar. The PEG does not require tokenization to
be a separate step, and tokenization rules can be written in the same way as
any other grammar rules."
)
(
license
license:expat
)))
(
define-public
sparse
(
package
(
name
"sparse"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment