Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
d739f481
Commit
d739f481
authored
9 years ago
by
Alex Kost
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add sox.
* gnu/packages/audio.scm (sox): New variable.
parent
a37f9722
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/audio.scm
+43
-0
43 additions, 0 deletions
gnu/packages/audio.scm
with
43 additions
and
0 deletions
gnu/packages/audio.scm
+
43
−
0
View file @
d739f481
...
@@ -2,6 +2,7 @@
...
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -45,6 +46,7 @@ (define-module (gnu packages audio)
...
@@ -45,6 +46,7 @@ (define-module (gnu packages audio)
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
gnome
)
#
:use-module
(
gnu
packages
gnome
)
#
:use-module
(
gnu
packages
gperf
)
#
:use-module
(
gnu
packages
gperf
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
qt
)
#
:use-module
(
gnu
packages
qt
)
#
:use-module
(
gnu
packages
linux
)
#
:use-module
(
gnu
packages
linux
)
...
@@ -1518,6 +1520,47 @@ (define-public soundtouch
...
@@ -1518,6 +1520,47 @@ (define-public soundtouch
control functionality, or just for playing around with the sound effects."
)
control functionality, or just for playing around with the sound effects."
)
(
license
license:lgpl2
.
1
+
)))
(
license
license:lgpl2
.
1
+
)))
(
define-public
sox
(
package
(
name
"sox"
)
(
version
"14.4.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/sox/sox-"
version
".tar.bz2"
))
(
sha256
(
base32
"170lx90r1nlnb2j6lg00524iwvqy72p48vii4xc5prrh8dnrb9l1"
))))
(
build-system
gnu-build-system
)
(
arguments
'
(
#
:configure-flags
;; The upstream asks to identify the distribution to diagnose SoX
;; bug reports.
'
(
"--with-distro=Guix System Distribution"
)))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"alsa-lib"
,
alsa-lib
)
(
"ao"
,
ao
)
(
"flac"
,
flac
)
(
"lame"
,
lame
)
(
"libid3tag"
,
libid3tag
)
(
"libltdl"
,
libltdl
)
(
"libmad"
,
libmad
)
(
"libpng"
,
libpng
)
(
"libvorbis"
,
libvorbis
)
(
"pulseaudio"
,
pulseaudio
)))
(
home-page
"http://sox.sourceforge.net"
)
(
synopsis
"Sound processing utility"
)
(
description
"SoX (Sound eXchange) is a command line utility that can convert
various formats of computer audio files to other formats. It can also
apply various effects to these sound files, and, as an added bonus, SoX
can play and record audio files."
)
;; sox.c is distributed under GPL, while the files that make up
;; libsox are licensed under LGPL.
(
license
(
list
license:gpl2+
license:lgpl2
.
1
+
))))
(
define-public
soxr
(
define-public
soxr
(
package
(
package
(
name
"soxr"
)
(
name
"soxr"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment