Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
d7678942
Commit
d7678942
authored
10 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add flexbar.
* gnu/packages/bioinformatics.scm (flexbar): New variable.
parent
d3517eda
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/bioinformatics.scm
+42
-0
42 additions, 0 deletions
gnu/packages/bioinformatics.scm
with
42 additions
and
0 deletions
gnu/packages/bioinformatics.scm
+
42
−
0
View file @
d7678942
...
@@ -21,6 +21,7 @@ (define-module (gnu packages bioinformatics)
...
@@ -21,6 +21,7 @@ (define-module (gnu packages bioinformatics)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
cmake
)
#
:use-module
(
guix
build-system
trivial
)
#
:use-module
(
guix
build-system
trivial
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
base
)
...
@@ -29,6 +30,7 @@ (define-module (gnu packages bioinformatics)
...
@@ -29,6 +30,7 @@ (define-module (gnu packages bioinformatics)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
python
))
#
:use-module
(
gnu
packages
python
))
#
:use-module
(
gnu
packages
tbb
)
(
define-public
bedtools
(
define-public
bedtools
(
package
(
package
...
@@ -139,6 +141,46 @@ (define-public bowtie
...
@@ -139,6 +141,46 @@ (define-public bowtie
(
supported-systems
'
(
"x86_64-linux"
))
(
supported-systems
'
(
"x86_64-linux"
))
(
license
license:gpl3+
)))
(
license
license:gpl3+
)))
(
define-public
flexbar
(
package
(
name
"flexbar"
)
(
version
"2.5"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/flexbar/"
version
"/flexbar_v"
version
"_src.tgz"
))
(
sha256
(
base32
"13jaykc3y1x8y5nn9j8ljnb79s5y51kyxz46hdmvvjj6qhyympmf"
))))
(
build-system
cmake-build-system
)
(
arguments
`
(
;; There is no test target, although there is a directory containing
;; test data and scripts (launched by flexbar_validate.sh).
#
:tests?
#f
#
:configure-flags
(
list
(
string-append
"-DFLEXBAR_BINARY_DIR="
(
assoc-ref
%outputs
"out"
)
"/bin/"
))
#
:phases
(
alist-delete
'install
%standard-phases
)))
(
inputs
`
((
"tbb"
,
tbb
)
(
"zlib"
,
zlib
)))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"seqan"
,
seqan
)))
(
home-page
"http://flexbar.sourceforge.net"
)
(
synopsis
"Barcode and adapter removal tool for sequencing platforms"
)
(
description
"Flexbar preprocesses high-throughput nucleotide sequencing data
efficiently. It demultiplexes barcoded runs and removes adapter sequences.
Moreover, trimming and filtering features are provided. Flexbar increases
read mapping rates and improves genome and transcriptome assemblies. It
supports next-generation sequencing data in fasta/q and csfasta/q format from
Illumina, Roche 454, and the SOLiD platform."
)
(
license
license:gpl3
)))
(
define-public
samtools
(
define-public
samtools
(
package
(
package
(
name
"samtools"
)
(
name
"samtools"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment