Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
dd8d6d65
Commit
dd8d6d65
authored
9 years ago
by
Sou Bunnbu (宋文武)
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add squashfs-tools.
* gnu/packages/compression.scm (squashfs-tools): New variable.
parent
5ef9d7de
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/compression.scm
+41
-0
41 additions, 0 deletions
gnu/packages/compression.scm
with
41 additions
and
0 deletions
gnu/packages/compression.scm
+
41
−
0
View file @
dd8d6d65
...
@@ -545,3 +545,44 @@ (define-public lz4
...
@@ -545,3 +545,44 @@ (define-public lz4
;; The libraries (lz4, lz4hc, and xxhash are BSD licenced. The command
;; The libraries (lz4, lz4hc, and xxhash are BSD licenced. The command
;; line interface programs (lz4, fullbench, fuzzer, datagen) are GPL2+.
;; line interface programs (lz4, fullbench, fuzzer, datagen) are GPL2+.
(
license
(
list
license:bsd-2
license:gpl2+
))))
(
license
(
list
license:bsd-2
license:gpl2+
))))
(
define-public
squashfs-tools
(
package
(
name
"squashfs-tools"
)
(
version
"4.3"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/squashfs/"
"squashfs"
version
".tar.gz"
))
(
sha256
(
base32
"1xpklm0y43nd9i6jw43y2xh5zvlmj9ar2rvknh0bh7kv8c95aq0d"
))))
(
build-system
gnu-build-system
)
(
arguments
'
(
#
:tests?
#f
; no check target
#
:make-flags
(
list
"CC=gcc"
"XZ_SUPPORT=1"
"LZO_SUPPORT=1"
"LZ4_SUPPORT=1"
(
string-append
"INSTALL_DIR="
%output
"/bin"
))
#
:phases
(
modify-phases
%standard-phases
(
replace
'configure
(
lambda
_
(
chdir
"squashfs-tools"
))))))
(
inputs
`
((
"lz4"
,
lz4
)
(
"lzo"
,
lzo
)
(
"xz"
,
xz
)
(
"zlib"
,
zlib
)))
(
home-page
"http://squashfs.sourceforge.net/"
)
(
synopsis
"Tools to create and extract squashfs filesystems"
)
(
description
"Squashfs is a highly compressed read-only filesystem for Linux. It uses
zlib to compress files, inodes, and directories. All blocks are packed to
minimize the data overhead, and block sizes of between 4K and 1M are supported.
It is intended to be used for archival use, for live CDs, and for embedded
systems where low overhead is needed. This package allows you to create and
extract such filesystems."
)
(
license
license:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment