Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
de0c3141
Commit
de0c3141
authored
10 years ago
by
Eric Bavier
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add perl-tk
* gnu/packages/tcl.scm (perl-tk): New variable
parent
34af3684
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/tcl.scm
+38
-0
38 additions, 0 deletions
gnu/packages/tcl.scm
with
38 additions
and
0 deletions
gnu/packages/tcl.scm
+
38
−
0
View file @
de0c3141
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -21,6 +22,11 @@ (define-module (gnu packages tcl)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
perl
)
#
:use-module
(
gnu
packages
libpng
)
#
:use-module
(
gnu
packages
libjpeg
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
xorg
)
#
:use-module
(
guix
licenses
))
...
...
@@ -159,3 +165,35 @@ (define-public tk
"Tk is a graphical toolkit for building graphical user interfaces
(GUIs) in the Tcl language."
)
(
license
(
package-license
tcl
))))
(
define-public
perl-tk
(
package
(
name
"perl-tk"
)
(
version
"804.032"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://cpan/authors/id/S/SR/SREZIC/Tk-"
version
".tar.gz"
))
(
sha256
(
base32
"0jarvplhfvnm0shhdm2a5zczlnk9mkf8jvfjiwyhjrr3cy1gl0w0"
))))
(
build-system
perl-build-system
)
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"libx11"
,
libx11
)
(
"libpng"
,
libpng
)
(
"libjpeg"
,
libjpeg
)))
(
arguments
`
(
#
:make-maker-flags
`
(
,
(
string-append
"X11="
(
assoc-ref
%build-inputs
"libx11"
)))))
(
synopsis
"Graphical user interface toolkit for Perl"
)
(
description
"Tk is a Graphical User Interface ToolKit."
)
(
home-page
(
string-append
"http://search.cpan.org/~srezic/Tk-"
version
))
;; From the package README: "... you can redistribute it and/or modify it
;; under the same terms as Perl itself, with the exception of all the
;; files in the pTk sub-directory which have separate terms derived from
;; those of the orignal Tix4.1.3 or Tk8.4.* sources. See the files
;; pTk/license.terms, pTk/license.html_lib, and pTk/Tix.license for
;; details of this license."
(
license
(
package-license
perl
))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment