Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
dec4b3aa
Unverified
Commit
dec4b3aa
authored
5 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add guile-srfi-159.
* gnu/packages/guile-xyz.scm (guile-srfi-159): New variable.
parent
e006f749
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/guile-xyz.scm
+31
-0
31 additions, 0 deletions
gnu/packages/guile-xyz.scm
with
31 additions
and
0 deletions
gnu/packages/guile-xyz.scm
+
31
−
0
View file @
dec4b3aa
...
@@ -84,6 +84,7 @@ (define-module (gnu packages guile-xyz)
...
@@ -84,6 +84,7 @@ (define-module (gnu packages guile-xyz)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
git-download
)
#
:use-module
(
guix
git-download
)
#
:use-module
(
guix
hg-download
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
guile
)
#
:use-module
(
guix
build-system
guile
)
#
:use-module
(
guix
utils
)
#
:use-module
(
guix
utils
)
...
@@ -2274,3 +2275,33 @@ (define-public guile-gi
...
@@ -2274,3 +2275,33 @@ (define-public guile-gi
libraries, such as GTK+3. Its README comes with the disclaimer: This is
libraries, such as GTK+3. Its README comes with the disclaimer: This is
pre-alpha code."
)
pre-alpha code."
)
(
license
license:gpl3+
))))
(
license
license:gpl3+
))))
(
define-public
guile-srfi-159
(
let
((
commit
"1bd98abda2ae4ef8f36761a167903e55c6bda7bb"
)
(
revision
"0"
))
(
package
(
name
"guile-srfi-159"
)
(
version
(
git-version
"0"
revision
commit
))
(
home-page
"https://bitbucket.org/bjoli/guile-srfi-159"
)
(
source
(
origin
(
method
hg-fetch
)
(
uri
(
hg-reference
(
changeset
commit
)
(
url
home-page
)))
(
sha256
(
base32
"1zw6cmcy7xdbfiz3nz9arqnn7l2daidaps6ixkcrc9b6k51fdv3p"
))
(
file-name
(
git-file-name
name
version
))))
(
build-system
guile-build-system
)
(
arguments
;; The *-impl.scm files are actually included from module files; they
;; should not be compiled separately, but they must be installed.
'
(
#
:not-compiled-file-regexp
"-impl\\.scm$"
))
(
inputs
`
((
"guile"
,
guile-2
.
2
)))
(
synopsis
"Formatting combinators for Guile"
)
(
description
"The @code{(srfi-159)} module and its sub-modules implement the
formatting combinators specified by
@uref{https://srfi.schemers.org/srfi-159/srfi-159.html, SRFI-159}. These are
more expressive and flexible than the traditional @code{format} procedure."
)
(
license
license:bsd-3
))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment