Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
e48e31bc
Unverified
Commit
e48e31bc
authored
8 years ago
by
Alex Kost
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add xfd.
* gnu/packages/xorg.scm (xfd): New variable.
parent
f225ae75
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/xorg.scm
+46
-0
46 additions, 0 deletions
gnu/packages/xorg.scm
with
46 additions
and
0 deletions
gnu/packages/xorg.scm
+
46
−
0
View file @
e48e31bc
...
...
@@ -3917,6 +3917,52 @@ (define-public xfontsel
Font Description (XLFD) full name for a font."
)
(
license
license:x11
)))
(
define-public
xfd
(
package
(
name
"xfd"
)
(
version
"1.1.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://xorg/individual/app/xfd-"
version
".tar.bz2"
))
(
sha256
(
base32
"0n97iqqap9wyxjan2n520vh4rrf5bc0apsw2k9py94dqzci258y1"
))))
(
build-system
gnu-build-system
)
(
arguments
;; The same 'app-defaults' problem as with 'xfontsel' package.
(
let
((
app-defaults-dir
"/share/X11/app-defaults"
))
`
(
#
:configure-flags
(
list
(
string-append
"--with-appdefaultdir="
%output
,
app-defaults-dir
))
#
:phases
(
modify-phases
%standard-phases
(
add-after
'install
'wrap-xfd
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let
((
out
(
assoc-ref
outputs
"out"
)))
(
wrap-program
(
string-append
out
"/bin/xfd"
)
`
(
"XAPPLRESDIR"
=
(
,
(
string-append
out
,
app-defaults-dir
)))))))))))
(
inputs
`
((
"fontconfig"
,
fontconfig
)
(
"libx11"
,
libx11
)
(
"libxaw"
,
libxaw
)
(
"libxft"
,
libxft
)
(
"libxmu"
,
libxmu
)
(
"libxrender"
,
libxrender
)))
(
native-inputs
`
((
"gettext"
,
gnu-gettext
)
(
"pkg-config"
,
pkg-config
)))
(
home-page
"https://www.x.org/wiki/"
)
(
synopsis
"Display all the characters in an X font"
)
(
description
"XFD (X Font Display) package provides an utility that displays a
window containing the name of the font being displayed, a row of command
buttons, several lines of text for displaying character metrics, and a grid
containing one glyph per cell."
)
(
license
license:x11
)))
(
define-public
xmodmap
(
package
(
name
"xmodmap"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment