Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
e5e45c06
Unverified
Commit
e5e45c06
authored
8 years ago
by
David Craven
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add libjaylink.
* gnu/packages/embedded.scm (libjaylink): New variable.
parent
3d74f12e
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/embedded.scm
+41
-0
41 additions, 0 deletions
gnu/packages/embedded.scm
with
41 additions
and
0 deletions
gnu/packages/embedded.scm
+
41
−
0
View file @
e5e45c06
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -28,11 +29,14 @@ (define-module (gnu packages embedded)
#
:use-module
(
guix
build-system
trivial
)
#
:use-module
(
guix
build
utils
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
cross-base
)
#
:use-module
(
gnu
packages
flex
)
#
:use-module
(
gnu
packages
gcc
)
#
:use-module
(
gnu
packages
gdb
)
#
:use-module
(
gnu
packages
libusb
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
texinfo
))
;; We must not use the released GCC sources here, because the cross-compiler
...
...
@@ -236,3 +240,40 @@ (define-public gdb-arm-none-eabi
"--enable-languages=c,c++"
"--disable-nls"
)
,@
(
package-arguments
gdb
)))))
(
define-public
libjaylink
;; No release tarballs available.
(
let
((
commit
"faa2a433fdd3de211728f3da5921133214af9dd3"
)
(
revision
"1"
))
(
package
(
name
"libjaylink"
)
(
version
(
string-append
"0.1.0-"
revision
"."
(
string-take
commit
7
)))
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
"git://git.zapb.de/libjaylink.git"
)
(
commit
commit
)))
(
file-name
(
string-append
name
"-"
version
"-checkout"
))
(
sha256
(
base32
"02crr56csz8whq3q4mrmdzzgwp5b0qvxm0fb18drclc3zj44yxl2"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"autoconf"
,
autoconf
)
(
"automake"
,
automake
)
(
"libtool"
,
libtool
)
(
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"libusb"
,
libusb
)))
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
(
add-before
'configure
'autoreconf
(
lambda
_
(
zero?
(
system*
"autoreconf"
"-vfi"
)))))))
(
home-page
"http://repo.or.cz/w/libjaylink.git"
)
(
synopsis
"Library to interface Segger J-Link devices"
)
(
description
"libjaylink is a shared library written in C to access
SEGGER J-Link and compatible devices."
)
(
license
license:gpl2+
))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment