Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
eb7c43c3
Commit
eb7c43c3
authored
9 years ago
by
David Thompson
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add bluez.
* gnu/packages/linux.scm (bluez): New variable.
parent
e5326da4
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/linux.scm
+38
-0
38 additions, 0 deletions
gnu/packages/linux.scm
with
38 additions
and
0 deletions
gnu/packages/linux.scm
+
38
−
0
View file @
eb7c43c3
...
...
@@ -55,6 +55,8 @@ (define-module (gnu packages linux)
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
docbook
)
#
:use-module
(
gnu
packages
asciidoc
)
#
:use-module
(
gnu
packages
readline
)
#
:use-module
(
gnu
packages
calendar
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
utils
)
...
...
@@ -2161,3 +2163,39 @@ (define-public libaio
system calls, important for the performance of databases and other advanced
applications."
)
(
license
lgpl2
.
1
+
)))
(
define-public
bluez
(
package
(
name
"bluez"
)
(
version
"5.30"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://www.kernel.org/pub/linux/bluetooth/bluez-"
version
".tar.xz"
))
(
sha256
(
base32
"0b1qbnq1xzcdw5rajg9yyg31bf21jnff0n6gnf1snz89bbdllfhy"
))))
(
build-system
gnu-build-system
)
(
arguments
'
(
#
:configure-flags
(
let
((
out
(
assoc-ref
%outputs
"out"
)))
(
list
"--disable-systemd"
;; Install dbus/udev files to the correct location.
(
string-append
"--with-dbusconfdir="
out
"/etc"
)
(
string-append
"--with-udevdir="
out
"/lib/udev"
)))))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"gettext"
,
gnu-gettext
)))
(
inputs
`
((
"glib"
,
glib
)
(
"dbus"
,
dbus
)
(
"eudev"
,
eudev
)
(
"libical"
,
libical
)
(
"readline"
,
readline
)))
(
home-page
"http://www.bluez.org/"
)
(
synopsis
"Linux Bluetooth protocol stack"
)
(
description
"BlueZ provides support for the core Bluetooth layers and protocols. It
is flexible, efficient and uses a modular implementation."
)
(
license
gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment