Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
ec8da0e2
Commit
ec8da0e2
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add setBfree.
* gnu/packages/audio.scm (setbfree): New variable.
parent
9e850534
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/music.scm
+46
-0
46 additions, 0 deletions
gnu/packages/music.scm
with
46 additions
and
0 deletions
gnu/packages/music.scm
+
46
−
0
View file @
ec8da0e2
...
...
@@ -38,6 +38,7 @@ (define-module (gnu packages music)
#
:use-module
(
gnu
packages
gcc
)
#
:use-module
(
gnu
packages
gettext
)
#
:use-module
(
gnu
packages
ghostscript
)
#
:use-module
(
gnu
packages
gl
)
#
:use-module
(
gnu
packages
gnome
)
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
guile
)
...
...
@@ -322,6 +323,51 @@ (define-public powertabeditor
Editor. It is compatible with Power Tab Editor 1.7 and Guitar Pro."
)
(
license
license:gpl3+
)))
(
define-public
setbfree
(
package
(
name
"setbfree"
)
(
version
"0.8.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/pantherb/setBfree/releases/download/v"
version
"/setbfree-"
version
".tar.gz"
))
(
sha256
(
base32
"045bgp7qsigpbrhk7qvgvliwiy26sajifwn7f2jvk90ckfqnlw4b"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:tests?
#f
; no "check" target
#
:make-flags
(
list
(
string-append
"PREFIX="
(
assoc-ref
%outputs
"out"
))
(
string-append
"FONTFILE="
(
assoc-ref
%build-inputs
"font-bitstream-vera"
)
"/share/fonts/truetype/VeraBd.ttf"
))
#
:phases
(
modify-phases
%standard-phases
(
add-before
'build
'set-CC-variable
(
lambda
_
(
setenv
"CC"
"gcc"
)
#t
))
(
delete
'configure
))))
(
inputs
`
((
"jack"
,
jack-1
)
(
"lv2"
,
lv2
)
(
"zita-convolver"
,
zita-convolver
)
(
"glu"
,
glu
)
(
"ftgl"
,
ftgl
)
(
"font-bitstream-vera"
,
font-bitstream-vera
)))
(
native-inputs
`
((
"help2man"
,
help2man
)
(
"pkg-config"
,
pkg-config
)))
(
home-page
"http://setbfree.org"
)
(
synopsis
"Tonewheel organ"
)
(
description
"setBfree is a MIDI-controlled, software synthesizer designed to imitate
the sound and properties of the electromechanical organs and sound
modification devices that brought world-wide fame to the names and products of
Laurens Hammond and Don Leslie."
)
(
license
license:gpl2+
)))
(
define-public
tuxguitar
(
package
(
name
"tuxguitar"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment