Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
f1d2872c
Commit
f1d2872c
authored
12 years ago
by
Cyril Roelandt
Committed by
Ludovic Courtès
12 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add irssi.
* gnu/packages/irssi.scm: New file. * Makefile.am (MODULES): Add it.
parent
b8d3511a
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
Makefile.am
+1
-0
1 addition, 0 deletions
Makefile.am
gnu/packages/irssi.scm
+65
-0
65 additions, 0 deletions
gnu/packages/irssi.scm
with
66 additions
and
0 deletions
Makefile.am
+
1
−
0
View file @
f1d2872c
...
@@ -84,6 +84,7 @@ MODULES = \
...
@@ -84,6 +84,7 @@ MODULES = \
gnu/packages/icu4c.scm
\
gnu/packages/icu4c.scm
\
gnu/packages/idutils.scm
\
gnu/packages/idutils.scm
\
gnu/packages/indent.scm
\
gnu/packages/indent.scm
\
gnu/packages/irssi.scm
\
gnu/packages/ld-wrapper.scm
\
gnu/packages/ld-wrapper.scm
\
gnu/packages/less.scm
\
gnu/packages/less.scm
\
gnu/packages/libapr.scm
\
gnu/packages/libapr.scm
\
...
...
This diff is collapsed.
Click to expand it.
gnu/packages/irssi.scm
0 → 100644
+
65
−
0
View file @
f1d2872c
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(
define-module
(
gnu
packages
irssi
)
#
:use-module
(
guix
licenses
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
glib
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
pkg-config
))
(
define-public
irssi
(
package
(
name
"irssi"
)
(
version
"0.8.15"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://www.irssi.org/files/irssi-"
version
".tar.bz2"
))
(
sha256
(
base32
"19m0aah9bhc70dnhh7kpydbsz5n35l0l9knxav1df0sic3xicbf1"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:phases
(
alist-replace
'configure
(
lambda*
(
#
:key
inputs
outputs
#
:allow-other-keys
)
(
let
((
out
(
assoc-ref
outputs
"out"
))
(
ncurses
(
assoc-ref
inputs
"ncurses"
)))
(
setenv
"CONFIG_SHELL"
(
which
"bash"
))
(
zero?
(
system*
"./configure"
(
string-append
"--prefix="
out
)
(
string-append
"--with-ncurses="
ncurses
)))))
%standard-phases
)))
(
inputs
`
((
"glib"
,
glib
)
(
"pkg-config"
,
pkg-config
)
(
"ncurses"
,
ncurses
)
(
"perl"
,
perl
)))
(
home-page
"http://www.irssi.org/"
)
(
synopsis
"Irssi, a terminal-based IRC client"
)
(
description
"Irssi is a terminal based IRC client for UNIX systems. It also supports
SILC and ICB protocols via plugins."
)
(
license
gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment