Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
f36617cb
Unverified
Commit
f36617cb
authored
5 years ago
by
John Soo
Committed by
Björn Höfling
5 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add coin3D.
* gnu/packages/graphics.scm (coin3D): New variable.
parent
4b481010
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/graphics.scm
+47
-0
47 additions, 0 deletions
gnu/packages/graphics.scm
with
47 additions
and
0 deletions
gnu/packages/graphics.scm
+
47
−
0
View file @
f36617cb
...
@@ -14,6 +14,7 @@
...
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -1059,3 +1060,49 @@ (define-public opencsg
...
@@ -1059,3 +1060,49 @@ (define-public opencsg
or by subtracting one shape from the other."
)
or by subtracting one shape from the other."
)
(
home-page
"http://www.opencsg.org/"
)
(
home-page
"http://www.opencsg.org/"
)
(
license
license:gpl2
))))
(
license
license:gpl2
))))
(
define-public
coin3D
(
package
(
name
"coin3D"
)
(
version
"4.0.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://bitbucket.org/Coin3D/coin/downloads/coin-"
version
"-src.zip"
))
(
sha256
(
base32
"1mqwlqzvc9ydfxi0bfskwlil16mbnkphfz36p0zl2mvw6h05aqh0"
))
(
modules
'
((
guix
build
utils
)))
(
snippet
'
(
begin
(
for-each
delete-file
'
(
"cfg/csubst.exe"
"cfg/wrapmsvc.exe"
))
#t
))))
(
build-system
cmake-build-system
)
(
native-inputs
`
((
"doxygen"
,
doxygen
)
(
"graphviz"
,
graphviz
)))
(
inputs
`
((
"boost"
,
boost
)
(
"freeglut"
,
freeglut
)
(
"glew"
,
glew
)))
(
arguments
`
(
#
:configure-flags
(
list
"-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
(
string-append
"-DBOOST_ROOT="
(
assoc-ref
%build-inputs
"boost"
)))))
(
home-page
"https://bitbucket.org/Coin3D/coin/wiki/Home"
)
(
synopsis
"High-level 3D visualization library with Open Inventor 2.1 API"
)
(
description
"Coin is a 3D graphics library with an Application Programming Interface
based on the Open Inventor 2.1 API. For those who are not familiar with
Open Inventor, it is a scene-graph based retain-mode rendering and model
interaction library, written in C++, which has become the de facto
standard graphics library for 3D visualization and visual simulation
software in the scientific and engineering community."
)
(
license
license:bsd-3
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment