Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
f3e22216
Unverified
Commit
f3e22216
authored
8 years ago
by
Julien Lepiller
Committed by
Kei Kebreau
8 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add fbida.
* gnu/packages/pdf.scm (fbida): New variable.
parent
b37e1e64
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/pdf.scm
+54
-0
54 additions, 0 deletions
gnu/packages/pdf.scm
with
54 additions
and
0 deletions
gnu/packages/pdf.scm
+
54
−
0
View file @
f3e22216
...
@@ -7,6 +7,7 @@
...
@@ -7,6 +7,7 @@
;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Coypright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Coypright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Coypright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Coypright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Coypright © 2016 Julien Lepiller <julien@lepiller.eu>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -45,6 +46,11 @@ (define-module (gnu packages pdf)
...
@@ -45,6 +46,11 @@ (define-module (gnu packages pdf)
#
:use-module
(
gnu
packages
gettext
)
#
:use-module
(
gnu
packages
gettext
)
#
:use-module
(
gnu
packages
backup
)
#
:use-module
(
gnu
packages
backup
)
#
:use-module
(
gnu
packages
lesstif
)
#
:use-module
(
gnu
packages
lesstif
)
#
:use-module
(
gnu
packages
linux
)
#
:use-module
(
gnu
packages
xdisorg
)
#
:use-module
(
gnu
packages
imagemagick
)
#
:use-module
(
gnu
packages
gl
)
#
:use-module
(
gnu
packages
photo
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
qt
)
#
:use-module
(
gnu
packages
qt
)
...
@@ -696,3 +702,51 @@ (define-public impressive
...
@@ -696,3 +702,51 @@ (define-public impressive
such as zooming, highlighting an area of the screen, and a tool to navigate
such as zooming, highlighting an area of the screen, and a tool to navigate
the PDF pages."
)
the PDF pages."
)
(
license
license:gpl2
)))
(
license
license:gpl2
)))
(
define-public
fbida
(
package
(
name
"fbida"
)
(
version
"2.12"
)
(
home-page
"https://www.kraxel.org/blog/linux/fbida/"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://www.kraxel.org/releases/fbida/"
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"0bw224vb7jh0lrqaf4jgxk48xglvxs674qcpj5y0axyfbh896cfk"
))))
(
build-system
gnu-build-system
)
(
arguments
'
(
#
:phases
(
alist-cons-after
'unpack
'patch-ldconfig
(
lambda
_
(
substitute*
"mk/Autoconf.mk"
((
"/sbin/ldconfig -p"
)
"echo lib"
))
#t
)
(
alist-delete
'configure
%standard-phases
))
#
:tests?
#f
#
:make-flags
(
list
"CC=gcc"
(
string-append
"prefix="
(
assoc-ref
%outputs
"out"
)))))
(
inputs
`
((
"libjpeg"
,
libjpeg
)
(
"curl"
,
curl
)
(
"libtiff"
,
libtiff
)
(
"libudev"
,
eudev
)
(
"libwebp"
,
libwebp
)
(
"libdrm"
,
libdrm
)
(
"imagemagick"
,
imagemagick
)
(
"giflib"
,
giflib
)
(
"glib"
,
glib
)
(
"cairo-xcb"
,
cairo-xcb
)
(
"freetype"
,
freetype
)
(
"fontconfig"
,
fontconfig
)
(
"libexif"
,
libexif
)
(
"mesa"
,
mesa
)
(
"libepoxy"
,
libepoxy
)
(
"libpng"
,
libpng
)
(
"poppler"
,
poppler
)))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
synopsis
"Framebuffer and drm-based image viewer"
)
(
description
"fbida contains a few applications for viewing and editing images on
the framebuffer."
)
(
license
license:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment