Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
f7283db3
Commit
f7283db3
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add BioPerl.
* gnu/packages/bioinformatics.scm (bioperl-minimal): New variable.
parent
14e2e44d
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/bioinformatics.scm
+63
-1
63 additions, 1 deletion
gnu/packages/bioinformatics.scm
with
63 additions
and
1 deletion
gnu/packages/bioinformatics.scm
+
63
−
1
View file @
f7283db3
...
@@ -51,7 +51,8 @@ (define-module (gnu packages bioinformatics)
...
@@ -51,7 +51,8 @@ (define-module (gnu packages bioinformatics)
#
:use-module
(
gnu
packages
vim
)
#
:use-module
(
gnu
packages
vim
)
#
:use-module
(
gnu
packages
web
)
#
:use-module
(
gnu
packages
web
)
#
:use-module
(
gnu
packages
xml
)
#
:use-module
(
gnu
packages
xml
)
#
:use-module
(
gnu
packages
zip
))
#
:use-module
(
gnu
packages
zip
)
#
:use-module
(
srfi
srfi-1
))
(
define-public
aragorn
(
define-public
aragorn
(
package
(
package
...
@@ -276,6 +277,67 @@ (define-public python2-pybedtools
...
@@ -276,6 +277,67 @@ (define-public python2-pybedtools
Python."
)
Python."
)
(
license
license:gpl2+
)))
(
license
license:gpl2+
)))
(
define-public
bioperl-minimal
(
let*
((
inputs
`
((
"perl-module-build"
,
perl-module-build
)
(
"perl-data-stag"
,
perl-data-stag
)
(
"perl-libwww"
,
perl-libwww
)
(
"perl-uri"
,
perl-uri
)))
(
transitive-inputs
(
map
(
compose
package-name
cadr
)
(
delete-duplicates
(
concatenate
(
map
(
compose
package-transitive-target-inputs
cadr
)
inputs
))))))
(
package
(
name
"bioperl-minimal"
)
(
version
"1.6.924"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://cpan/authors/id/C/CJ/CJFIELDS/BioPerl-"
version
".tar.gz"
))
(
sha256
(
base32
"1l3npcvvvwjlhkna9dndpfv1hklhrgva013kw96m0n1wpd37ask1"
))))
(
build-system
perl-build-system
)
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
(
add-after
'install
'wrap-programs
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
;; Make sure all executables in "bin" find the required Perl
;; modules at runtime. As the PERL5LIB variable contains also
;; the paths of native inputs, we pick the transitive target
;; inputs from %build-inputs.
(
let*
((
out
(
assoc-ref
outputs
"out"
))
(
bin
(
string-append
out
"/bin/"
))
(
path
(
string-join
(
cons
(
string-append
out
"/lib/perl5/site_perl"
)
(
map
(
lambda
(
name
)
(
assoc-ref
%build-inputs
name
))
',transitive-inputs
))
":"
)))
(
for-each
(
lambda
(
file
)
(
wrap-program
file
`
(
"PERL5LIB"
":"
prefix
(
,path
))))
(
find-files
bin
"\\.pl$"
))
#t
))))))
(
inputs
inputs
)
(
native-inputs
`
((
"perl-test-most"
,
perl-test-most
)))
(
home-page
"http://search.cpan.org/dist/BioPerl"
)
(
synopsis
"Bioinformatics toolkit"
)
(
description
"BioPerl is the product of a community effort to produce Perl code which
is useful in biology. Examples include Sequence objects, Alignment objects
and database searching objects. These objects not only do what they are
advertised to do in the documentation, but they also interact - Alignment
objects are made from the Sequence objects, Sequence objects have access to
Annotation and SeqFeature objects and databases, Blast objects can be
converted to Alignment objects, and so on. This means that the objects
provide a coordinated and extensible framework to do computational biology."
)
(
license
(
package-license
perl
)))))
(
define-public
python-biopython
(
define-public
python-biopython
(
package
(
package
(
name
"python-biopython"
)
(
name
"python-biopython"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment