Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
f7ee7a9b
Commit
f7ee7a9b
authored
9 years ago
by
Eric Bavier
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add Perl GD.
* gnu/packages/gd.scm (perl-gd): New variable.
parent
4ec48644
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/gd.scm
+51
-0
51 additions, 0 deletions
gnu/packages/gd.scm
with
51 additions
and
0 deletions
gnu/packages/gd.scm
+
51
−
0
View file @
f7ee7a9b
;;; GNU Guix --- Functional package management for GNU
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -20,8 +21,10 @@
...
@@ -20,8 +21,10 @@
(
define-module
(
gnu
packages
gd
)
(
define-module
(
gnu
packages
gd
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
perl
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
fontutils
)
#
:use-module
(
gnu
packages
fontutils
)
#
:use-module
(
gnu
packages
compression
)
#
:use-module
(
gnu
packages
compression
)
...
@@ -66,3 +69,51 @@ (define-public gd
...
@@ -66,3 +69,51 @@ (define-public gd
most common applications of GD involve website development."
)
most common applications of GD involve website development."
)
(
license
(
non-copyleft
"file://COPYING"
(
license
(
non-copyleft
"file://COPYING"
"See COPYING file in the distribution."
))))
"See COPYING file in the distribution."
))))
(
define-public
perl-gd
(
package
(
name
"perl-gd"
)
(
version
"2.56"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://cpan/authors/id/L/LD/LDS/"
"GD-"
version
".tar.gz"
))
(
sha256
(
base32
"1ya8f9hpiax8j29vwaiwlvvgah0vkyvpzva28r8231nyk0f3s40z"
))
(
patches
(
list
(
search-patch
"perl-gd-options-passthrough-and-fontconfig.patch"
)))))
(
build-system
perl-build-system
)
(
native-inputs
`
((
"perl-module-build"
,
perl-module-build
)))
;needs Module::Build >= 0.42
(
inputs
`
((
"gd"
,
gd
)
(
"zlib"
,
zlib
)
(
"png"
,
libpng
)
(
"ft"
,
freetype
)
(
"jpeg"
,
libjpeg
)
(
"fontconfig"
,
fontconfig
)))
(
arguments
;; We must use Build.PL for building because Makefile.PL fails to build
;; the XS source.
`
(
#
:module-build-flags
(
map
(
lambda
(
i
)
(
string-append
"--lib_"
i
"_path="
(
assoc-ref
%build-inputs
i
)))
'
(
"zlib"
"png"
"ft"
"jpeg"
"fontconfig"
))
#
:phases
(
alist-cons-after
'configure
'clear-autogenerated-files
(
lambda
_
;; This file is autogenerated by its .PLS script at build
;; time, but file creation fails because that file already
;; exists in the distribution with non-writable
;; permissions, so delete it first.
(
delete-file
"bdf_scripts/bdf2gdfont.pl"
))
%standard-phases
)))
(
home-page
"http://search.cpan.org/dist/GD"
)
(
synopsis
"Perl interface to the GD graphics library"
)
(
description
"GD.pm is an autoloadable interface module for libgd, a
popular library for creating and manipulating PNG files. With this library
you can create PNG images on the fly or modify existing files."
)
(
license
(
package-license
perl
))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment