Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
fa468e87
Commit
fa468e87
authored
10 years ago
by
Federico Beffa
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add ghc-parsec.
* gnu/packages/haskell.scm (ghc-parsec): New variable.
parent
d692228e
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/haskell.scm
+32
-0
32 additions, 0 deletions
gnu/packages/haskell.scm
with
32 additions
and
0 deletions
gnu/packages/haskell.scm
+
32
−
0
View file @
fa468e87
...
@@ -716,4 +716,36 @@ (define-public ghc-split
...
@@ -716,4 +716,36 @@ (define-public ghc-split
parts, akin to the 'split' function found in several mainstream languages."
)
parts, akin to the 'split' function found in several mainstream languages."
)
(
license
bsd-3
)))
(
license
bsd-3
)))
(
define-public
ghc-parsec
(
package
(
name
"ghc-parsec"
)
(
version
"3.1.9"
)
(
outputs
'
(
"out"
"doc"
))
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://hackage.haskell.org/package/parsec/parsec-"
version
".tar.gz"
))
(
sha256
(
base32
"1ja20cmj6v336jy87c6h3jzjp00sdbakwbdwp11iln499k913xvi"
))))
(
build-system
haskell-build-system
)
(
inputs
`
((
"ghc-hunit"
,
ghc-hunit
)))
;; these inputs are necessary to use this library
(
propagated-inputs
`
((
"ghc-text"
,
ghc-text
)
(
"ghc-mtl"
,
ghc-mtl
)))
(
arguments
`
(
#
:tests?
#f
))
; FIXME: currently missing libraries used for tests.
(
home-page
"https://github.com/aslatter/parsec"
)
(
synopsis
"Monadic parser combinators"
)
(
description
"Parsec is a parser library. It is simple, safe, well
documented, has extensive libraries, good error messages, and is fast. It is
defined as a monad transformer that can be stacked on arbitrary monads, and it
is also parametric in the input stream type."
)
(
license
bsd-3
)))
;;; haskell.scm ends here
;;; haskell.scm ends here
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment