Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
11c38cbe
Commit
11c38cbe
authored
10 years ago
by
John Darrington
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add xboing
* gnu/packages/games.scm (xboing): New variable.
parent
998fb8fa
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/games.scm
+54
-0
54 additions, 0 deletions
gnu/packages/games.scm
with
54 additions
and
0 deletions
gnu/packages/games.scm
+
54
−
0
View file @
11c38cbe
...
...
@@ -24,6 +24,7 @@ (define-module (gnu packages games)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
admin
)
#
:use-module
(
gnu
packages
boost
)
#
:use-module
(
gnu
packages
gettext
)
#
:use-module
(
gnu
packages
gl
)
...
...
@@ -321,3 +322,56 @@ (define-public xboard
fully interactive graphical interface and it can load and save games in the
Portable Game Notation."
)
(
license
gpl3+
)))
(
define-public
xboing
(
package
(
name
"xboing"
)
(
version
"2.4"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://www.techrescue.org/xboing/xboing"
version
".tar.gz"
))
(
sha256
(
base32
"16m2si8wmshxpifk861vhpqviqxgcg8bxj6wfw8hpnm4r2w9q0b7"
))))
(
arguments
`
(
#
:tests?
#f
#
:phases
(
alist-replace
'configure
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
substitute*
"Imakefile"
((
"XPMINCLUDE[\t ]*= -I/usr/X11/include/X11"
)
(
string-append
"XPMINCLUDE = -I"
(
assoc-ref
%build-inputs
"libxpm"
)
"/include/X11"
)))
(
substitute*
"Imakefile"
((
"XBOING_DIR = \\."
)
"XBOING_DIR=$(PROJECTROOT)"
))
;; FIXME: HIGH_SCORE_FILE should be set to somewhere writeable
(
zero?
(
system*
"xmkmf"
"-a"
(
string-append
"-DProjectRoot="
(
assoc-ref
outputs
"out"
)))))
(
alist-replace
'install
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
and
(
zero?
(
system*
"make"
"install.man"
))
(
zero?
(
system*
"make"
"install"
))))
%standard-phases
))))
(
inputs
`
((
"libx11"
,
libx11
)
(
"libxext"
,
libxext
)
(
"libxpm"
,
libxpm
)))
(
native-inputs
`
((
"imake"
,
imake
)
(
"inetutils"
,
inetutils
)
(
"makedepend"
,
makedepend
)))
(
build-system
gnu-build-system
)
(
home-page
"http://www.techrescue.org/xboing"
)
(
synopsis
"Ball and paddle game"
)
(
description
"XBoing is a blockout type game where you have a paddle which
you control to bounce a ball around the game zone destroying blocks with a
proton ball. Each block carries a different point value. The more blocks you
destroy, the better your score. The person with the highest score wins."
)
(
license
(
x11-style
"file://COPYING"
"Very similar to the X11 licence."
))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment