Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
36742f43
Commit
36742f43
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add Couger.
* gnu/packages/bioinformatics.scm (couger): New variable.
parent
0931c609
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/bioinformatics.scm
+71
-0
71 additions, 0 deletions
gnu/packages/bioinformatics.scm
with
71 additions
and
0 deletions
gnu/packages/bioinformatics.scm
+
71
−
0
View file @
36742f43
...
...
@@ -34,6 +34,7 @@ (define-module (gnu packages bioinformatics)
#
:use-module
(
gnu
packages
file
)
#
:use-module
(
gnu
packages
java
)
#
:use-module
(
gnu
packages
linux
)
#
:use-module
(
gnu
packages
machine-learning
)
#
:use-module
(
gnu
packages
maths
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
perl
)
...
...
@@ -438,6 +439,76 @@ (define-public clipper
"CLIPper is a tool to define peaks in CLIP-seq datasets."
)
(
license
license:gpl2
)))
(
define-public
couger
(
package
(
name
"couger"
)
(
version
"1.8.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://couger.oit.duke.edu/static/assets/COUGER"
version
".zip"
))
(
sha256
(
base32
"04p2b14nmhzxw5h72mpzdhalv21bx4w9b87z0wpw0xzxpysyncmq"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:tests?
#f
#
:phases
(
modify-phases
%standard-phases
(
delete
'configure
)
(
delete
'build
)
(
replace
'install
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let
((
out
(
assoc-ref
outputs
"out"
)))
(
copy-recursively
"src"
(
string-append
out
"/src"
))
(
mkdir
(
string-append
out
"/bin"
))
;; Add "src" directory to module lookup path.
(
substitute*
"couger"
((
"from argparse"
)
(
string-append
"import sys\nsys.path.append(\""
out
"\")\nfrom argparse"
)))
(
copy-file
"couger"
(
string-append
out
"/bin/couger"
)))
#t
))
(
add-after
'install
'wrap-program
(
lambda*
(
#
:key
inputs
outputs
#
:allow-other-keys
)
;; Make sure 'couger' runs with the correct PYTHONPATH.
(
let*
((
out
(
assoc-ref
outputs
"out"
))
(
path
(
getenv
"PYTHONPATH"
)))
(
wrap-program
(
string-append
out
"/bin/couger"
)
`
(
"PYTHONPATH"
":"
prefix
(
,path
))))
#t
)))))
(
inputs
`
((
"python"
,
python-2
)
(
"python2-pillow"
,
python2-pillow
)
(
"python2-numpy"
,
python2-numpy
)
(
"python2-scipy"
,
python2-scipy
)
(
"python2-matplotlib"
,
python2-matplotlib
)))
(
propagated-inputs
`
((
"r"
,
r
)
(
"libsvm"
,
libsvm
)
(
"randomjungle"
,
randomjungle
)))
(
native-inputs
`
((
"unzip"
,
unzip
)))
(
home-page
"http://couger.oit.duke.edu"
)
(
synopsis
"Identify co-factors in sets of genomic regions"
)
(
description
"COUGER can be applied to any two sets of genomic regions bound by
paralogous TFs (e.g., regions derived from ChIP-seq experiments) to identify
putative co-factors that provide specificity to each TF. The framework
determines the genomic targets uniquely-bound by each TF, and identifies a
small set of co-factors that best explain the in vivo binding differences
between the two TFs.
COUGER uses classification algorithms (support vector machines and random
forests) with features that reflect the DNA binding specificities of putative
co-factors. The features are generated either from high-throughput TF-DNA
binding data (from protein binding microarray experiments), or from large
collections of DNA motifs."
)
(
license
license:gpl3+
)))
(
define-public
clustal-omega
(
package
(
name
"clustal-omega"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment