Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
52650a4d
Unverified
Commit
52650a4d
authored
8 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add sbcl-cl-uglify-js.
* gnu/packages/lisp.scm (sbcl-cl-uglify-js): New variable.
parent
476b583f
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/lisp.scm
+40
-0
40 additions, 0 deletions
gnu/packages/lisp.scm
with
40 additions
and
0 deletions
gnu/packages/lisp.scm
+
40
−
0
View file @
52650a4d
...
@@ -1301,3 +1301,43 @@ (define-public sbcl-iterate
...
@@ -1301,3 +1301,43 @@ (define-public sbcl-iterate
@item it isn't part of the ANSI standard for Common Lisp.
@item it isn't part of the ANSI standard for Common Lisp.
@end itemize\n"
)
@end itemize\n"
)
(
license
license:expat
)))
(
license
license:expat
)))
(
define-public
sbcl-cl-uglify-js
;; There have been many bug fixes since the 2010 release.
(
let
((
commit
"429c5e1d844e2f96b44db8fccc92d6e8e28afdd5"
)
(
revision
"1"
))
(
package
(
name
"sbcl-cl-uglify-js"
)
(
version
(
string-append
"0.1-"
revision
"."
(
string-take
commit
9
)))
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
"https://github.com/mishoo/cl-uglify-js.git"
)
(
commit
commit
)))
(
sha256
(
base32
"0k39y3c93jgxpr7gwz7w0d8yknn1fdnxrjhd03057lvk5w8js27a"
))))
(
build-system
asdf-build-system/sbcl
)
(
inputs
`
((
"sbcl-parse-js"
,
sbcl-parse-js
)
(
"sbcl-cl-ppcre"
,
sbcl-cl-ppcre
)
(
"sbcl-cl-ppcre-unicode"
,
sbcl-cl-ppcre-unicode
)
(
"sbcl-parse-number"
,
sbcl-parse-number
)
(
"sbcl-iterate"
,
sbcl-iterate
)))
(
home-page
"https://github.com/mishoo/cl-uglify-js"
)
(
synopsis
"JavaScript compressor library for Common Lisp"
)
(
description
"This is a Common Lisp version of UglifyJS, a JavaScript
compressor. It works on data produced by @code{parse-js} to generate a
@dfn{minified} version of the code. Currently it can:
@itemize
@item reduce variable names (usually to single letters)
@item join consecutive @code{var} statements
@item resolve simple binary expressions
@item group most consecutive statements using the ``sequence'' operator (comma)
@item remove unnecessary blocks
@item convert @code{IF} expressions in various ways that result in smaller code
@item remove some unreachable code
@end itemize\n"
)
(
license
license:zlib
))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment