Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
7adb5299
Unverified
Commit
7adb5299
authored
4 years ago
by
Jan (janneke) Nieuwenhuizen
Committed by
Jan Nieuwenhuizen
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add sparse.
* gnu/packages/c.scm (sparse): New variable.
parent
5c7e477c
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/c.scm
+36
-0
36 additions, 0 deletions
gnu/packages/c.scm
with
36 additions
and
0 deletions
gnu/packages/c.scm
+
36
−
0
View file @
7adb5299
...
...
@@ -6,6 +6,7 @@
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -252,3 +253,38 @@ (define-public libhx
string formatting and autoresizing, option and config file parsing, type
checking casts and more."
)
(
license
license:lgpl2
.
1
+
)))
(
define-public
sparse
(
package
(
name
"sparse"
)
(
version
"0.6.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://kernel.org/software/devel/sparse/dist/"
"sparse-"
version
".tar.xz"
))
(
sha256
(
base32
"0qavyryxmhd1rf11akgn1nq3r15k11bqa3qajaq36a56r225rc7x"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"perl"
,
perl
)))
(
arguments
'
(
#
:make-flags
`
(
,
(
string-append
"PREFIX="
(
assoc-ref
%outputs
"out"
)))
#
:phases
(
modify-phases
%standard-phases
(
delete
'configure
)
(
add-after
'unpack
'patch-cgcc
(
lambda
_
(
substitute*
"cgcc"
((
"'cc'"
)
(
string-append
"'"
(
which
"gcc"
)
"'"
)))
#t
)))))
(
synopsis
"Semantic C parser for Linux development"
)
(
description
"Sparse is a semantic parser for C and is required for Linux development.
It provides a compiler frontend capable of parsing most of ANSI C as well as
many GCC extensions, and a collection of sample compiler backends, including a
static analyzer also called @file{sparse}. Sparse provides a set of
annotations designed to convey semantic information about types, such as what
address space pointers point to, or what locks a function acquires or
releases."
)
(
home-page
"https://sparse.wiki.kernel.org/index.php/Main_Page"
)
(
license
license:expat
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment