Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
d10fa5c7
Unverified
Commit
d10fa5c7
authored
8 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add intel-gpu-tools.
* gnu/packages/admin.scm (intel-gpu-tools): New variable.
parent
d71b758f
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/admin.scm
+52
-1
52 additions, 1 deletion
gnu/packages/admin.scm
with
52 additions
and
1 deletion
gnu/packages/admin.scm
+
52
−
1
View file @
d10fa5c7
...
@@ -8,7 +8,7 @@
...
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016
, 2017
Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
...
@@ -67,10 +67,12 @@ (define-module (gnu packages admin)
...
@@ -67,10 +67,12 @@ (define-module (gnu packages admin)
#
:use-module
(
gnu
packages
texinfo
)
#
:use-module
(
gnu
packages
texinfo
)
#
:use-module
(
gnu
packages
groff
)
#
:use-module
(
gnu
packages
groff
)
#
:use-module
(
gnu
packages
pciutils
)
#
:use-module
(
gnu
packages
pciutils
)
#
:use-module
(
gnu
packages
libunwind
)
#
:use-module
(
gnu
packages
libusb
)
#
:use-module
(
gnu
packages
libusb
)
#
:use-module
(
gnu
packages
libftdi
)
#
:use-module
(
gnu
packages
libftdi
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
xorg
)
#
:use-module
(
gnu
packages
xorg
)
#
:use-module
(
gnu
packages
xdisorg
)
#
:use-module
(
gnu
packages
python
)
#
:use-module
(
gnu
packages
python
)
#
:use-module
(
gnu
packages
man
)
#
:use-module
(
gnu
packages
man
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
autotools
)
...
@@ -1997,3 +1999,52 @@ (define-public sedsed
...
@@ -1997,3 +1999,52 @@ (define-public sedsed
With sedsed you can master any sed script. No more secrets, no more hidden
With sedsed you can master any sed script. No more secrets, no more hidden
buffers."
)
buffers."
)
(
license
license:expat
)))
(
license
license:expat
)))
(
define-public
intel-gpu-tools
(
package
(
name
"intel-gpu-tools"
)
(
version
"1.18"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://cgit.freedesktop.org/xorg/app/"
"intel-gpu-tools/snapshot/"
"intel-gpu-tools-"
version
".tar.gz"
))
(
sha256
(
base32
"0w7djk0y5w76hzn1b3cm39zd5c6w9za1wfn80wd857h0v313rzq3"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:tests?
#f
; many of the tests try to load kernel modules
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'autogen
(
lambda
_
;; Don't run configure in this phase
(
setenv
"NOCONFIGURE"
"1"
)
(
zero?
(
system*
"sh"
"autogen.sh"
)))))))
(
inputs
`
((
"util-macros"
,
util-macros
)
(
"libdrm"
,
libdrm
)
(
"libpciaccess"
,
libpciaccess
)
(
"kmod"
,
kmod
)
(
"procps"
,
procps
)
(
"cairo"
,
cairo
)
(
"libunwind"
,
libunwind
)
(
"libxrandr"
,
libxrandr
)
(
"glib"
,
glib
)))
(
native-inputs
`
((
"autoconf"
,
autoconf
)
(
"automake"
,
automake
)
(
"libtool"
,
libtool
)
(
"pkg-config"
,
pkg-config
)))
(
home-page
"https://cgit.freedesktop.org/xorg/app/intel-gpu-tools/"
)
(
synopsis
"Tools for development and testing of the Intel DRM driver"
)
(
description
"Intel GPU Tools is a collection of tools for development and
testing of the Intel DRM driver. There are many macro-level test suites that
get used against the driver, including xtest, rendercheck, piglit, and
oglconform, but failures from those can be difficult to track down to kernel
changes, and many require complicated build procedures or specific testing
environments to get useful results. Therefore, Intel GPU Tools includes
low-level tools and tests specifically for development and testing of the
Intel DRM Driver."
)
(
license
license:expat
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment